]> code.ossystems Code Review - openembedded-core.git/commitdiff
perl: Standardise config.sh location
authorRichard Purdie <rpurdie@linux.intel.com>
Mon, 16 Nov 2009 10:56:17 +0000 (10:56 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Mon, 16 Nov 2009 10:56:17 +0000 (10:56 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/classes/cpan-base.bbclass
meta/classes/cpan.bbclass
meta/classes/cpan_build.bbclass
meta/packages/perl/perl-native_5.8.8.bb
meta/packages/perl/perl.inc
meta/packages/perl/perl_5.8.8.bb

index 919a9b06a518a49bc5304a9e908637a85ce51248..82fd5b459abd1017fc95c6119f01acb41e7238f8 100644 (file)
@@ -10,7 +10,7 @@ RDEPENDS  += "${@["perl", ""][(bb.data.inherits_class('native', d))]}"
 # Determine the staged version of perl from the perl configuration file
 def get_perl_version(d):
        import re
-       cfg = bb.data.expand('${STAGING_DIR}/${HOST_SYS}/perl/config.sh', d)
+       cfg = bb.data.expand('${STAGING_LIBDIR}/perl/config.sh', d)
        try:
                f = open(cfg, 'r')
        except IOError:
index ca5303d97f47cc97a13cb1618e180e889a82b2cf..66054bc755def9fe01b6c0150d8e5e4ca03d01b5 100644 (file)
@@ -10,11 +10,13 @@ export PERLCONFIGTARGET = "${@is_target(d)}"
 
 # Env var which tells perl where the perl include files are
 export PERL_INC = "${STAGING_LIBDIR}/perl/${@get_perl_version(d)}/CORE"
+export PERL_LIB = "${STAGING_DATADIR}/perl/${@get_perl_version(d)}"
+export PERL_ARCHLIB = "${STAGING_LIBDIR}/perl/${@get_perl_version(d)}"
 
 cpan_do_configure () {
        yes '' | perl Makefile.PL ${EXTRA_CPANFLAGS}
        if [ "${BUILD_SYS}" != "${HOST_SYS}" ]; then
-               . ${STAGING_DIR}/${TARGET_SYS}/perl/config.sh
+               . ${STAGING_LIBDIR}/perl/config.sh
                if [ "${IS_NEW_PERL}" = "yes" ]; then
                        sed -i -e "s:\(SITELIBEXP = \).*:\1${sitelibexp}:" \
                                -e "s:\(SITEARCHEXP = \).*:\1${sitearchexp}:" \
index 9cfe72bcb79732d57592a448b475150ef03223d9..6cac85c5fe0c5e152f0ab66adec1cc9cd87df00b 100644 (file)
@@ -22,7 +22,7 @@ DEPENDS_prepend = "${@cpan_build_dep_prepend(d)}"
 cpan_build_do_configure () {
        if [ ${@is_target(d)} == "yes" ]; then
                # build for target
-               . ${STAGING_DIR}/${TARGET_SYS}/perl/config.sh
+               . ${STAGING_LIBDIR}/perl/config.sh
                if [ "${IS_NEW_PERL}" = "yes" ]; then
                        perl Build.PL --installdirs vendor \
                                --destdir ${D} \
index e2bdaee30a08d639e50cda7409ff92f2d790e204..fb8be281bf1f01265434646de6661f36619227d8 100644 (file)
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.perl.org/"
 SECTION = "libs"
 LICENSE = "Artistic|GPL"
 DEPENDS = "virtual/db-native gdbm-native"
-PR = "r13"
+PR = "r14"
 
 SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
            file://perl-5.8.8-gcc-4.2.patch;patch=1 \
@@ -61,8 +61,8 @@ do_stage_append() {
         # We need a hostperl link for building perl
         ln -sf ${STAGING_BINDIR_NATIVE}/perl${PV} ${STAGING_BINDIR_NATIVE}/hostperl
         # Store native config in non-versioned directory
-        install -d ${STAGING_DIR}/${HOST_SYS}/perl
-        install config.sh ${STAGING_DIR}/${HOST_SYS}/perl
+        install -d ${STAGING_LIBDIR}/perl
+        install config.sh ${STAGING_LIBDIR}/perl
 }
 
 PARALLEL_MAKE = ""
index 9e20ae63e613a0065cc77cecb3df88ede1c2287e..15ae55cf174119baa86eb7b4be7b8d0cbd5bdeb6 100644 (file)
@@ -36,8 +36,8 @@ do_install() {
 }
 
 do_stage() {
-       install -d ${STAGING_DIR}/${HOST_SYS}/perl/
-       install config.sh ${STAGING_DIR}/${HOST_SYS}/perl/
+       install -d ${STAGING_LIBDIR}/perl/
+       install config.sh ${STAGING_LIBDIR}/perl/
 }
 
 PACKAGES_DYNAMIC = "perl-module-*"
index 977852ac21a2c32fa3dd5d64d8e9c8c4d4359493..0696de577ffde587dc8db65b3e0d56a6fb214363 100644 (file)
@@ -137,11 +137,10 @@ do_install() {
         fi
 }
 do_stage() {
-        install -d ${STAGING_DIR}/${HOST_SYS}/perl \
-                   ${STAGING_LIBDIR_NATIVE}/perl/${PV} \
+        install -d ${STAGING_LIBDIR_NATIVE}/perl/${PV} \
                    ${STAGING_LIBDIR}/perl/${PV}/CORE
         # target config, used by cpan.bbclass to extract version information
-        install config.sh ${STAGING_DIR}/${HOST_SYS}/perl/
+        install config.sh ${STAGING_LIBDIR}/perl/
         # target configuration, used by native perl when cross-compiling
         install lib/Config_heavy.pl ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy-target.pl
         # perl shared library headers