]> code.ossystems Code Review - openembedded-core.git/commitdiff
python-pygobject: use Python 2 instead of Python 3
authorRoss Burton <ross.burton@intel.com>
Tue, 22 Mar 2016 20:53:51 +0000 (20:53 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 24 Mar 2016 21:44:27 +0000 (21:44 +0000)
Ideally this would be an option but that means conditional inherits.  For now
Python 2 is clearly the default Python in oe-core so switch to Python 2 instead
of 3.

This stops python3 being pulled inadvertently into builds, and appearing in
images that have ptest-pkgs installed (via dbus-test).

Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/python/python-pygobject_3.18.2.bb

index e61d75ca3e950b8cb7249e58a805e78e1c6b7df7..8fe1d63423ef6563aad9a7fc8e924870e24e2513 100644 (file)
@@ -3,9 +3,9 @@ SECTION = "devel/python"
 LICENSE = "LGPLv2.1"
 LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
 
-inherit autotools pkgconfig gnomebase distutils3-base gobject-introspection
+inherit autotools pkgconfig gnomebase distutils-base gobject-introspection
 
-DEPENDS += "python3 glib-2.0 gnome-common"
+DEPENDS += "python glib-2.0 gnome-common"
 
 SRCNAME="pygobject"
 SRC_URI = " \
@@ -20,6 +20,6 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
 
 BBCLASSEXTEND = "native"
 
-EXTRA_OECONF = "--disable-cairo"
+EXTRA_OECONF = "--disable-cairo --with-python=python2.7"
 
-RDEPENDS_${PN} += "python3-setuptools"
+RDEPENDS_${PN} += "python-setuptools"