]> code.ossystems Code Review - openembedded-core.git/commitdiff
Update meta-ide-support dependencies
authorScott Garman <scott.a.garman@intel.com>
Thu, 7 Oct 2010 20:45:20 +0000 (13:45 -0700)
committerRichard Purdie <rpurdie@linux.intel.com>
Thu, 7 Oct 2010 21:07:45 +0000 (22:07 +0100)
Using poky-qemu with our new tap networking and/or unfs support
required too many additional build steps. This updates the
meta-ide-support dependencies so all features are built and
available to use.

Specifically, this adds psuedo-native, qemu-helper-native, and
unfs-server-native to the dependency chain for meta-ide-support.

This fixes [BUGID #392]

Also add poky-gen-tapdevs and remove runqemu-nfs from the
qemu-helper-native recipe, and update some qemu control script
error messages to suggest building meta-ide-support.

Signed-off-by: Scott Garman <scott.a.garman@intel.com>
meta/recipes-devtools/qemu/qemu-helper-nativesdk_1.0.bb
meta/recipes-devtools/unfs-server/unfs-server_2.2beta47.bb
meta/recipes-tbd/meta/meta-ide-support.bb
scripts/poky-export-rootfs
scripts/poky-find-native-sysroot
scripts/poky-qemu-ifdown
scripts/poky-qemu-ifup

index 473411db92f3ad89c2de26241b58768d745e8686..791465694b4c7491c15261041889b6b41e4359a9 100644 (file)
@@ -1,19 +1,19 @@
 DESCRIPTION = "Qemu helper scripts from Poky"
 LICENSE = "GPL"
 RDEPENDS = "qemu-nativesdk"
-PR = "r7"
+PR = "r8"
 
 FILESPATH = "${FILE_DIRNAME}/qemu-helper"
 
 SRC_URI = "file://${POKYBASE}/scripts/poky-qemu \
            file://${POKYBASE}/scripts/poky-qemu-internal \
            file://${POKYBASE}/scripts/poky-addptable2image \
+           file://${POKYBASE}/scripts/poky-gen-tapdevs \
            file://${POKYBASE}/scripts/poky-qemu-ifup \
            file://${POKYBASE}/scripts/poky-qemu-ifdown \
            file://${POKYBASE}/scripts/poky-find-native-sysroot \
            file://${POKYBASE}/scripts/poky-extract-sdk \
            file://${POKYBASE}/scripts/poky-export-rootfs \
-           file://${POKYBASE}/scripts/runqemu-nfs \
            file://tunctl.c \
            file://raw2flash.c \
           "
@@ -31,7 +31,6 @@ do_compile() {
 do_install() {
        install -d ${D}${bindir}
        install -m 0755 ${WORKDIR}${POKYBASE}/scripts/poky-* ${D}${bindir}/
-       install -m 0755 ${WORKDIR}${POKYBASE}/scripts/runqemu-nfs ${D}${bindir}/
        install tunctl ${D}${bindir}/
        install raw2flash.spitz ${D}${bindir}/
        install flash2raw.spitz ${D}${bindir}/
index ecba4525a2f2d1e8767da7347a38e56afe4e930b..66012189dc52c0526b5ef3f2fe01a5ebcfc82f68 100644 (file)
@@ -3,7 +3,8 @@ SECTION = "console/network"
 LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
 
-PR = "r0"
+RDEPENDS = "pseudo"
+PR = "r1"
 
 SRC_URI = "ftp://linux.mathematik.tu-darmstadt.de/pub/linux/oldstuff/people/okir/nfs-server-${PV}.tar.gz \
            file://001-2.2b47-2.2b51.patch \
index 70a0c64aba311599ea1c12824b4d2ebc1e409258..8fe9a23036ff05207b17ed188b7211b0ffe181ec 100644 (file)
@@ -1,6 +1,6 @@
 DESCRIPTION = "Meta package for ensuring the build directory contains all appropriate toolchain packages for using an IDE"
 LICENSE = "MIT"
-DEPENDS = "virtual/libc gdb-cross"
+DEPENDS = "virtual/libc gdb-cross qemu-helper-native unfs-server-native"
 PR = "r1"
 
 inherit meta toolchain-scripts
index f3552516ad3978d9b960d6c7044750b73727f4e2..3ab0597c9a99f2ee7164bd4edc51f8dcf341c632 100755 (executable)
@@ -50,7 +50,7 @@ if [ ! -e "$POKY_NATIVE_SYSROOT/usr/sbin/rpc.mountd" ]; then
        echo "Error: Unable to find rpc.mountd binary in $POKY_NATIVE_SYSROOT/usr/sbin/"
 
        if [ "x$POKY_DISTRO_VERSION" = "x" ]; then
-           echo "Have you run 'bitbake unfs-server-native'?"
+           echo "Have you run 'bitbake meta-ide-support'?"
        else
            echo "This shouldn't happen - something is missing from your toolchain installation"
        fi
index 9182f9d170b843e3219ef90f2d712b25699273e1..d8002f963ecdb9d5087b8225e76b402298a162dd 100755 (executable)
@@ -60,7 +60,7 @@ if [ ! -e "$POKY_NATIVE_SYSROOT/usr/bin/pseudo" ]; then
     echo "Error: Unable to find pseudo binary in $POKY_NATIVE_SYSROOT/usr/bin/"
 
     if [ "x$POKY_DISTRO_VERSION" = "x" ]; then
-        echo "Have you run 'bitbake pseudo-native'?"
+        echo "Have you run 'bitbake meta-ide-support'?"
     else
         echo "This shouldn't happen - something is wrong with your toolchain installation"
     fi
index ece2dc998abdc5e370b0387e3aff10d436a79baf..60ca919deaa8974f347edc1b785fa5d721fc4957 100755 (executable)
@@ -50,7 +50,7 @@ if [ ! -e "$TUNCTL" ]; then
        if [[ "$NATIVE_SYSROOT_DIR" =~ ^\/opt\/poky ]]; then
                echo "This shouldn't happen - something is wrong with your toolchain installation"
        else
-               echo "Have you run 'bitbake qemu-helper-native'?"
+               echo "Have you run 'bitbake meta-ide-support'?"
        fi
 
        exit 1
index cd4c47b60814fb6d52e0e52b4e7bbb5e87322c33..8685c83cce41ea0393516087c8b4df1e3289b1fe 100755 (executable)
@@ -57,7 +57,7 @@ if [ ! -x "$TUNCTL" ]; then
        if [[ "$NATIVE_SYSROOT_DIR" =~ ^\/opt\/poky ]]; then
                echo "This shouldn't happen - something is wrong with your toolchain installation"
        else
-               echo "Have you run 'bitbake qemu-helper-native'?"
+               echo "Have you run 'bitbake meta-ide-support'?"
        fi
        
        exit 1