]> code.ossystems Code Review - openembedded-core.git/commitdiff
native.bbclass: Add virtclass-native to OVERRIDES and use in fakeroot to function...
authorRichard Purdie <rpurdie@linux.intel.com>
Mon, 5 Jan 2009 22:00:22 +0000 (22:00 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Mon, 5 Jan 2009 22:00:22 +0000 (22:00 +0000)
meta/classes/native.bbclass
meta/packages/fakeroot/fakeroot_1.9.4.bb

index 91ea9b547dd7984db13ab663f1d9e26d210cbc5c..98b62a05499a1d841047e8111f49d8c13c57abf9 100644 (file)
@@ -129,5 +129,6 @@ python __anonymous () {
             #else:
             #    bb.note("%s has rouge PROVIDES of %s which doesn't end in -sdk?" % (pn, prov))
     bb.data.setVar("PROVIDES", provides, d)
+    bb.data.setVar("OVERRIDES", bb.data.getVar("OVERRIDES", d, False) + ":virtclass-native", d)
 }
 
index 04219519edb5ce22f45333d39385cb35e912808b..669fa5a38f1d22e2049babe37abe7d2f0a15294d 100644 (file)
@@ -4,6 +4,7 @@ SECTION = "base"
 LICENSE = "GPL"
 # fakeroot needs getopt which is provided by the util-linux package
 RDEPENDS = "util-linux"
+RDEPENDS_virtclass-native = "util-linux-native"
 PR = "r2"
 
 SRC_URI = "${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.tar.gz \