]> code.ossystems Code Review - openembedded-core.git/commitdiff
udev: use 'echo' instead of 'echo -n' in init script
authorOtavio Salvador <otavio@ossystems.com.br>
Thu, 5 Jan 2012 06:30:47 +0000 (22:30 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 5 Jan 2012 11:19:19 +0000 (11:19 +0000)
Avoid using two stage progress output to avoid text garbage during
parallel boot.

Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/udev/udev/init
meta/recipes-core/udev/udev_164.bb

index d0d7e5d0e32871813e162fa76999504a9c276a78..bfbac0d95d7fda7580624cbbadc64eb5fc790e64 100644 (file)
@@ -25,7 +25,7 @@ kill_udevd() {
 
 export ACTION=add
 # propagate /dev from /sys
-echo -n "Starting udev"
+echo "Starting udev"
 
 # mount the tmpfs on /dev, if not already done
 LANG=C awk '$2 == "/dev" && ($3 == "tmpfs" || $3 == "devtmpfs") { exit 1 }' /proc/mounts && {
@@ -55,5 +55,4 @@ else
        /sbin/udevadm settle
 fi
 
-echo
 exit 0
index f952c907c1b8ebe1bccfbbf44492ae3f2b6a023d..6d71f4dc1b853a1a189a98fc6e58e57c70d54817 100644 (file)
@@ -1,6 +1,6 @@
 include udev.inc
 
-PR = "r8"
+PR = "r10"
 
 SRC_URI += "file://udev-166-v4l1-1.patch"