]> code.ossystems Code Review - openembedded-core.git/commitdiff
Fix postinstall scripts not to use IMAGE_ROOTFS direction by use D instead. Based...
authorRichard Purdie <rpurdie@linux.intel.com>
Fri, 23 Jan 2009 16:15:06 +0000 (16:15 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 23 Jan 2009 16:15:06 +0000 (16:15 +0000)
meta/packages/dpkg/dpkg.inc
meta/packages/modutils/modutils_2.4.27.bb
meta/packages/opkg/opkg_svn.bb

index 041b437abdd576e3c619802f36f3a038667df2af..67c0781ce802b47c7b760a36a546a95367a2332a 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "Package maintenance system for Debian."
 LICENSE = "GPL"
 SECTION = "base"
-PR = "r6"
+PR = "r7"
 
 SRC_URI = "${DEBIAN_MIRROR}/main/d/dpkg/dpkg_${PV}.tar.gz \
            file://ignore_extra_fields.patch;patch=1 \
@@ -19,13 +19,13 @@ DPKG_INIT_POSITION_slugos = "41"
 pkg_postinst_dpkg () {
 #!/bin/sh
 if [ "x$D" != "x" ]; then
-       install -d ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d
+       install -d $D/${sysconfdir}/rcS.d
        # this happens at S98 where our good 'ole packages script used to run
        echo -e "#!/bin/sh
        dpkg --configure -a
        rm -f /${sysconfdir}/rcS.d/S${DPKG_INIT_POSITION}configure
 " > ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S${DPKG_INIT_POSITION}configure
-       chmod 0755 ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S${DPKG_INIT_POSITION}configure
+       chmod 0755 $D/${sysconfdir}/rcS.d/S${DPKG_INIT_POSITION}configure
 fi
 }
 
index 119e219f7f8ff444645a78d1690e9c6a40281711..a5a9231322fc1412f287c4a93cf71f0798641c11 100644 (file)
@@ -3,7 +3,7 @@ DESCRIPTION = "These utilities are intended to make a Linux modular kernel \
 manageable for all users, administrators and distribution maintainers."
 LICENSE = "GPLv2"
 DEPENDS = "bison-native"
-PR = "r8"
+PR = "r9"
 
 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/kernel/modutils/v2.4/modutils-${PV}.tar.bz2 \
            file://lex.l.diff;patch=1 \
@@ -40,9 +40,9 @@ done
 if test -n "$D"; then
        D="-r $D"
        if test -n "`which ${TARGET_PREFIX}depmod-2.4`"; then
-               for kerneldir in `ls -p ${IMAGE_ROOTFS}/lib/modules|grep /`; do
+               for kerneldir in `ls -p $D/lib/modules|grep /`; do
                        kernelver=`basename $kerneldir`
-                       ${TARGET_PREFIX}depmod-2.4 -a -b ${IMAGE_ROOTFS} -C ${IMAGE_ROOTFS}/${sysconfdir}/modules.conf -r $kernelver
+                       ${TARGET_PREFIX}depmod-2.4 -a -b $D -C ${IMAGE_ROOTFS}/${sysconfdir}/modules.conf -r $kernelver
                done
        fi
 fi
index 92796a394fdd8d6000cd3a2fe059909f19383536..4517cfff1cad48d3d60aa8f1a9dc3a864d518ec5 100644 (file)
@@ -6,7 +6,7 @@ RCONFLICTS_update-alternatives-cworth = "update-alternatives-dpkg"
 RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives}"
 PACKAGE_ARCH_update-alternatives-cworth = "all"
 
-PR = "r8"
+PR = "r9"
 
 PACKAGES =+ "libopkg-dev libopkg update-alternatives-cworth"
 
@@ -36,8 +36,8 @@ if [ "x$D" != "x" ]; then
        echo "#!/bin/sh
 opkg-cl configure
 rm -f /${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure
-" > ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure
-       chmod 0755 ${IMAGE_ROOTFS}${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure
+" > $D${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure
+       chmod 0755 $D${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure
 fi
 
 update-alternatives --install ${bindir}/opkg opkg ${bindir}/opkg-cl 100