]> code.ossystems Code Review - openembedded-core.git/commitdiff
icu: Make sure changes apply to Makefile and Makefile.in to fix build failure
authorRichard Purdie <rpurdie@linux.intel.com>
Wed, 4 Aug 2010 09:13:25 +0000 (10:13 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Wed, 4 Aug 2010 10:43:12 +0000 (11:43 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/icu/icu-3.6.inc
meta/packages/icu/icu_3.6.bb

index aa654f768e9bf2c077793f2ec94f1844facb75ac..1c611bdf3674c55a23cd7643bbd01b35848477df 100644 (file)
@@ -24,15 +24,13 @@ do_configure() {
        libtoolize --force
        gnu-configize --force
        oe_runconf
-       if [ "${BUILD_ARCH}" != "${HOST_ARCH}" ]; then
+       if [ "${PN}" != "icu-native" ]; then
                # In the non-native case we need to make substitutions to use
                # the native versions of the tools
-               for i in */Makefile */*.inc */*/Makefile */*/*.inc ; do
+               for i in */Makefile* */*.inc */*/Makefile* */*/*.inc */*/*.inc.in ; do
                        sed -i -e 's:$(INVOKE) $(BINDIR)/:$(INVOKE) :g' $i 
                        sed -i -e 's:$(BINDIR)/::g' $i 
                done
-               sed -i -e 's:$(BINDIR)/::g' extra/uconv/pkgdata.inc || true
-               sed -i -e 's:$(BINDIR)/::g' extra/uconv/pkgdata.inc.in || true
        fi
 }
 
index 7938dc63dc5ffe64c168c9aa3c26150c087b63c2..50421160098a8b63622831cefb015ab06972707d 100644 (file)
@@ -1,3 +1,3 @@
 require icu-3.6.inc
 
-PR = "r5"
+PR = "r6"