]> code.ossystems Code Review - openembedded-core.git/commitdiff
valgrind: fix buildpath QA issue
authorHongxu Jia <hongxu.jia@windriver.com>
Fri, 18 Mar 2016 09:01:46 +0000 (05:01 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 20 Mar 2016 22:57:59 +0000 (22:57 +0000)
Pass DEBUG_FLAGS to SELECTED_OPTIMIZATION which fixes build
path issue in DWARF.

[YOCTO #8457]

Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/valgrind/valgrind_3.11.0.bb

index e8a235781b899511bbc4b1f16b2410a8b851c99d..51c88bf7aa082438fa9578e42830ce579622cacb 100644 (file)
@@ -49,8 +49,9 @@ EXTRA_OEMAKE = "-w"
 
 # valgrind likes to control its own optimisation flags. It generally defaults
 # to -O2 but uses -O0 for some specific test apps etc. Passing our own flags
-# (via CFLAGS) means we interfere with that.
-SELECTED_OPTIMIZATION = ""
+# (via CFLAGS) means we interfere with that. Only pass DEBUG_FLAGS to it
+# which fixes build path issue in DWARF.
+SELECTED_OPTIMIZATION = "${DEBUG_FLAGS}"
 
 CFLAGS_append_libc-uclibc = " -D__UCLIBC__ "