]> code.ossystems Code Review - openembedded-core.git/commitdiff
chkconfig: use ${sysconfdir} instead of /etc for packaging
authorJavier Martinez Canillas <javier@dowhile0.org>
Sun, 5 Aug 2012 19:48:55 +0000 (21:48 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 6 Aug 2012 13:38:26 +0000 (14:38 +0100)
It is considered good practice to use the build system provided
variables instead of directly specify hardcoded paths.

Signed-off-by: Javier Martinez Canillas <javier@dowhile0.org>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/chkconfig/chkconfig_1.3.58.bb

index 17987a660e22939ee9a51928a465ce21b29a77ae..9e0e1a05f0a955c7f7f70545170b0179dea75810 100644 (file)
@@ -12,7 +12,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
 
 DEPENDS = "libnewt popt"
 
-PR = "r1"
+PR = "r2"
 
 SRC_URI = "http://fedorahosted.org/releases/c/h/chkconfig/${BPN}-${PV}.tar.bz2"
 
@@ -24,6 +24,6 @@ inherit autotools gettext
 EXTRA_OEMAKE += 'MANDIR="${mandir}" BINDIR="${base_sbindir}" SBINDIR="${sbindir}"'
 
 do_install_append() {
-    mkdir -p ${D}/etc/chkconfig.d
+    mkdir -p ${D}${sysconfdir}/chkconfig.d
     rm -f ${D}${sbindir}/update-alternatives
 }