]> code.ossystems Code Review - openembedded-core.git/commitdiff
libnl2: Fix a race on route/pktloc_syntax.h
authorTom Rini <tom_rini@mentor.com>
Fri, 30 Sep 2011 17:21:23 +0000 (12:21 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 14 Oct 2011 11:53:30 +0000 (12:53 +0100)
At issue is that route/pktloc.c (not generated) depends on
route/pktloc_syntax.h (generated).

Signed-off-by: Tom Rini <tom_rini@mentor.com>
Signed-off-by: Matthew McClintock <msm@freescale.com>
meta/recipes-support/libnl/fix-pktloc_syntax_h-race.patch [new file with mode: 0644]
meta/recipes-support/libnl/libnl_2.0.bb

diff --git a/meta/recipes-support/libnl/fix-pktloc_syntax_h-race.patch b/meta/recipes-support/libnl/fix-pktloc_syntax_h-race.patch
new file mode 100644 (file)
index 0000000..05d75db
--- /dev/null
@@ -0,0 +1,26 @@
+Upstream-Status: Inappropriate [configuration]
+
+libnl has progressed to 0.3.2 and there does not appear to be any
+"make -j" issues with this build after my limited testing on that
+newer version so we can assume this issue is fixed upstream
+
+Index: libnl-2.0/lib/Makefile.am
+===================================================================
+--- libnl-2.0.orig/lib/Makefile.am
++++ libnl-2.0/lib/Makefile.am
+@@ -27,11 +27,15 @@ CLEANFILES = \
+       route/pktloc_grammar.c route/pktloc_grammar.h \
+       route/pktloc_syntax.c route/pktloc_syntax.h
++BUILT_SOURCES = route/pktloc_syntax.h route/pktloc_grammar.h
++
+ # Hack to avoid using ylwrap. It does not function correctly in combination
+ # with --header-file=
++route/pktloc_grammar.h: route/pktloc_grammar.c
+ route/pktloc_grammar.c: route/pktloc_grammar.l
+       $(LEX) --header-file=route/pktloc_grammar.h $(LFLAGS) -o $@ $^
++route/pktloc_syntax.h: route/pktloc_syntax.c
+ route/pktloc_syntax.c: route/pktloc_syntax.y
+       $(YACC) -d $(YFLAGS) -o $@ $^
index 0dfcaf63a733983ce1b1072337aedcc7030e250a..5339846599c762af32e1ec5a63c832f409c7fc16 100644 (file)
@@ -6,10 +6,11 @@ LICENSE = "LGPLv2.1"
 LIC_FILES_CHKSUM = "file://COPYING;md5=2b41e13261a330ee784153ecbb6a82bc"
 
 DEPENDS = "flex-native bison-native"
-PR = "r2"
+PR = "r3"
 
 SRC_URI= "http://www.infradead.org/~tgr/libnl/files/${BPN}-${PV}.tar.gz \
           file://fix-makefile.patch \
+         file://fix-pktloc_syntax_h-race.patch \
          "
 
 SRC_URI[md5sum] = "6aaf1e9802a17a7d702bb0638044ffa7"