]> code.ossystems Code Review - openembedded-core.git/commitdiff
cpan-base: Add vardepvalue to get_perl_version function
authorMartin Jansa <martin.jansa@gmail.com>
Wed, 4 Dec 2013 17:32:43 +0000 (18:32 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 11 Feb 2014 12:00:39 +0000 (12:00 +0000)
* without this bitbake -S perf shows following error:
  ERROR: Bitbake's cached basehash does not match the one we just generated
    (/OE/oe-core/meta/recipes-kernel/perf/perf.bb.do_package)!
  if you run it twice, once without perl in sysroot and once with perl
  already built

(From OE-Core master rev: f31f6a70ec24e8c9515d69c5092e15effc5e7d4d)

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/cpan-base.bbclass

index 7e1e8d0d6b1a2238c9d49908ef44c27b1137c304..aa502d5faac1fd65cf62a8c70a202a6e88fbd651 100644 (file)
@@ -10,6 +10,9 @@ RDEPENDS_${PN} += "${@["perl", ""][(bb.data.inherits_class('native', d))]}"
 PERL_OWN_DIR = "${@["", "/perl-native"][(bb.data.inherits_class('native', d))]}"
 
 # Determine the staged version of perl from the perl configuration file
+# Assign vardepvalue, because otherwise signature is changed before and after
+# perl is built (from None to real version in config.sh).
+get_perl_version[vardepvalue] = "${PERL_OWN_DIR}"
 def get_perl_version(d):
     import re
     cfg = d.expand('${STAGING_LIBDIR}${PERL_OWN_DIR}/perl/config.sh')