]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto-rt: qemumips: fix boot panic
authorBruce Ashfield <bruce.ashfield@windriver.com>
Thu, 25 Aug 2011 20:45:57 +0000 (16:45 -0400)
committerSaul Wold <sgw@linux.intel.com>
Fri, 26 Aug 2011 19:34:02 +0000 (12:34 -0700)
Fixes [YOCTO #1392]

Updating the SRCREVs to pickup:

[
    mips/rt: convert cascade interrupt non threaded

    The preempt_rt kernel forces all irq interrupts to be threaded,
    but special interrupts can be excluded from this conversion.
    The cascade interrupt should be part of these exceptions.

    In this case, irq2 is initialized before "kthreadd" task, which
    converts irq interrupt to threaded.

    If this irq is threaded, the kernel calls "try_to_wake_up" function
    to wake up "kthreadd" task, but at that moment, "kthreadd" task
    has no been initialize and try_to_wake_up wakes up a NULL task.

Signed-off-by: Liming Wang <liming.wang@windriver.com>
]

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb

index 16daddfe086d31123631fcc1a79a3c99c6057590..2bee5435a942b0223c76fea54f80fe8ae31c6897 100644 (file)
@@ -14,8 +14,8 @@ KBRANCH_qemuppc = "yocto/standard/preempt-rt/qemu-ppc32"
 LINUX_VERSION ?= "3.0.3"
 LINUX_KERNEL_TYPE = "preempt-rt"
 
-SRCREV_machine ?= "67ce0924042a2faa12b71ac3e92175c789c32af6"
-SRCREV_machine_qemuppc ?= "839638f4efda0c70c6f491161ab2c042f5bc3e66"
+SRCREV_machine ?= "c86423d29c94525d18ef1c9b6c025f733c1e8252"
+SRCREV_machine_qemuppc ?= "ccb47c9e8d85dc00ccd28bc6819d7769e2c11cb3"
 SRCREV_meta ?= "5b535279e61197cb194bb2dfceb8b7a04128387c"
 
 PR = "r0"