]> code.ossystems Code Review - openembedded-core.git/commitdiff
insane.bbclass: Checking for NLS too when checking gettext dependency
authorKhem Raj <raj.khem@gmail.com>
Fri, 22 Apr 2011 18:28:08 +0000 (11:28 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 3 May 2011 23:52:20 +0000 (00:52 +0100)
Checking for gettext is not needed when --disable-nls is used

Let user know what variant of gettext is missing e.g. gettext-native,
gettext-nativesdk etc, reveals a bit more for user

Check for virtual/gettext

Signed-off-by: Khem Raj <raj.khem@gmail.com>
meta/classes/insane.bbclass

index a3ea0e5ef0c00990533b18c667e5ef8a2497dc23..742be5e66a2b0f20f0357dc1d5ca48ddec6542ce 100644 (file)
@@ -578,7 +578,8 @@ Rerun configure task after fixing this. The path was '%s'""" % root)
         if "configure.in" in files:
             configs.append(os.path.join(root, "configure.in"))
 
-    if "gettext" not in bb.data.getVar('P', d, True) and "gcc-runtime" not in bb.data.getVar('P', d, True):
+    cnf = bb.data.getVar('EXTRA_OECONF', d, True) or ""
+    if "gettext" not in bb.data.getVar('P', d, True) and "gcc-runtime" not in bb.data.getVar('P', d, True) and "--disable-nls" not in cnf:
        if bb.data.inherits_class('native', d) or bb.data.inherits_class('cross', d) or bb.data.inherits_class('crosssdk', d) or bb.data.inherits_class('nativesdk', d):
           gt = "gettext-native"
        elif bb.data.inherits_class('cross-canadian', d):
@@ -590,8 +591,8 @@ Rerun configure task after fixing this. The path was '%s'""" % root)
           for config in configs:
               gnu = "grep \"^[[:space:]]*AM_GNU_GETTEXT\" %s >/dev/null" % config
               if os.system(gnu) == 0:
-                 bb.fatal("""Gettext required but not in DEPENDS for file %s.
-Missing inherit gettext?""" % config)
+                 bb.fatal("""%s required but not in DEPENDS for file %s.
+Missing inherit gettext?""" % (gt, config))
 
     if not package_qa_check_license(workdir, d):
         bb.fatal("Licensing Error: LIC_FILES_CHKSUM does not match, please fix")