]> code.ossystems Code Review - openembedded-core.git/commitdiff
Package the icon for dates and contacts, add svn version of
authorChris Lord <chris@openedhand.com>
Fri, 30 Sep 2005 18:07:27 +0000 (18:07 +0000)
committerChris Lord <chris@openedhand.com>
Fri, 30 Sep 2005 18:07:27 +0000 (18:07 +0000)
matchbox-themes-extra

git-svn-id: https://svn.o-hand.com/repos/poky@90 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/contacts/contacts_0.0.bb
openembedded/packages/dates/dates_svn.bb
openembedded/packages/matchbox-themes-extra/matchbox-themes-extra_svn.bb [new file with mode: 0644]

index 02a8903206226aa74ba94bcd8686bbcce24b07ba..faca7c4685a058015a46cb3391b208d9fc73ce66 100755 (executable)
@@ -3,9 +3,11 @@ SECTION = "x11"
 DEPENDS = "glib-2.0 gtk+ libglade eds-dbus"
 MAINTAINER = "Chris Lord <chris@openedhand.com>"
 DESCRIPTION = "Contacts is an address-book application."
-PR = "r1"
-
+PR = "r2"
 
 SRC_URI = "file:///tmp/${PN}-${PV}.tar.gz"
 
 inherit autotools pkgconfig
+
+FILES_${PN} += "${datadir}/icons/hicolor/48x48/apps/oh-contacts.png"
+
index eea555c9499f9be780245c2b2bf10a8b7594d67f..784d5545cf3851acc7af50cf2a2abbce46d0d7cd 100755 (executable)
@@ -4,7 +4,7 @@ DEPENDS = "glib-2.0 gtk+ libglade eds-dbus"
 MAINTAINER = "Chris Lord <chris@openedhand.com>"
 DESCRIPTION = "Dates is a calendar application."
 
-PR = "r1"
+PR = "r2"
 
 PV = "0.0cvs${CVSDATE}"
 S = "${WORKDIR}/${PN}"
@@ -13,3 +13,4 @@ SRC_URI = "svn://svn.o-hand.com/repos/;module=${PN};proto=http"
 
 inherit autotools pkgconfig
 
+FILES_${PN} += "${datadir}/icons/hicolor/48x48/apps/oh-dates.png"
diff --git a/openembedded/packages/matchbox-themes-extra/matchbox-themes-extra_svn.bb b/openembedded/packages/matchbox-themes-extra/matchbox-themes-extra_svn.bb
new file mode 100644 (file)
index 0000000..b3a4f30
--- /dev/null
@@ -0,0 +1,30 @@
+DESCRIPTION = "Matchbox window manager extra themes"
+LICENSE = "GPL"
+DEPENDS = "matchbox-wm"
+SECTION = "x11/wm"
+PV = "0.3cvs${CVSDATE}"
+
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=matchbox-themes-extra;proto=http"
+S = "${WORKDIR}/${PN}"
+
+inherit autotools pkgconfig
+
+# split into several packages plus one meta package
+PACKAGES = "${PN} ${PN}-industrial ${PN}-expose ${PN}-mbcrystal ${PN}-clearlooks"
+
+ALLOW_EMPTY_${PN} = 1
+FILES_${PN} = ""
+RDEPENDS_${PN} = "${PN}-industrial ${PN}-expose ${PN}-mbcrystal ${PN}-clearlooks"
+
+FILES_${PN}-industrial = "${datadir}/themes/Industrial \
+                         ${datadir}/icons/Industrial"
+
+FILES_${PN}-expose = "${datadir}/themes/expose \
+                     ${datadir}/icons/expose"
+
+FILES_${PN}-mbcrystal = "${datadir}/themes/mbcrystal \
+                        ${datadir}/icons/mbcrystal"
+
+FILES_${PN}-clearlooks = "${datadir}/themes/Clearlooks \
+                         ${datadir}/icons/Clearlooks"
+