]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add packagegroup-core-buildessential
authorColin Walters <walters@verbum.org>
Mon, 24 Sep 2012 23:54:42 +0000 (19:54 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 17 Oct 2012 16:32:21 +0000 (17:32 +0100)
[Not heavily tested, but sent for discussion]

task-core-sdk is too big - for example, I simply don't want to ship tcl, ever =)
Historically distcc caused a large dependency graph explosion because it has
a utility which uses gtk+, although that was fixed.

packagegroup-core-sdk also includes coreutils, which is a bit
confusing; conceptually things dependent on coreutils should pull it
in explicitly, or possibly we just declare coreutils to be in the
minimal build set.

So packagegroup-core-buildessential is intended to be similar to
Debian's "build-essential" package.  It's the stuff needed by say 80+%
of components, not worth repeating over and over.

Signed-off-by: Colin Walters <walters@verbum.org>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-core/packagegroups/packagegroup-core-buildessential.bb [new file with mode: 0644]
meta/recipes-core/packagegroups/packagegroup-core-sdk.bb

diff --git a/meta/recipes-core/packagegroups/packagegroup-core-buildessential.bb b/meta/recipes-core/packagegroups/packagegroup-core-buildessential.bb
new file mode 100644 (file)
index 0000000..164da36
--- /dev/null
@@ -0,0 +1,30 @@
+#
+# Copyright (C) 2007 OpenedHand Ltd.
+# Copyright (C) 2012 Red Hat, Inc.
+#
+
+SUMMARY = "Essential build dependencies"
+LICENSE = "MIT"
+PR = "r0"
+
+inherit packagegroup
+
+RDEPENDS_packagegroup-core-buildessential = "\
+    autoconf \
+    automake \
+    binutils \
+    binutils-symlinks \
+    cpp \
+    cpp-symlinks \
+    gcc \
+    gcc-symlinks \
+    g++ \
+    g++-symlinks \
+    gettext \
+    make \
+    libstdc++ \
+    libstdc++-dev \
+    libtool \
+    pkgconfig \
+    "
+
index b00bf0704cfdd97f520dfc215ade870cc8de8328..985bebd3b4a283a2361bb13746713552d2a9ae96 100644 (file)
@@ -16,28 +16,13 @@ RREPLACES_packagegroup-core-sdk = "task-core-sdk"
 RCONFLICTS_packagegroup-core-sdk = "task-core-sdk"
 
 RDEPENDS_packagegroup-core-sdk = "\
-    autoconf \
-    automake \
-    binutils \
-    binutils-symlinks \
+    packagegroup-core-buildessential \
     coreutils \
-    cpp \
-    cpp-symlinks \
     ccache \
     diffutils \
-    gcc \
-    gcc-symlinks \
-    g++ \
-    g++-symlinks \
-    gettext \
-    make \
     intltool \
-    libstdc++ \
-    libstdc++-dev \
-    libtool \
     perl-module-re \
     perl-module-text-wrap \
-    pkgconfig \
     findutils \
     quilt \
     less \