]> code.ossystems Code Review - openembedded-core.git/commitdiff
at: modify sources in do_patch
authorRoss Burton <ross.burton@intel.com>
Wed, 4 Nov 2015 19:45:39 +0000 (19:45 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 16 Nov 2015 11:32:43 +0000 (11:32 +0000)
Instead of copying the forked source files into ${S} in do_compile_prepend(), do
it in a do_patch() postfunc.  This ensures that the source archiver sees the
changes for compliance and legal verification.

Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-extended/at/at_3.1.16.bb

index 0512bcb836466273b33805fc9d4e93b0f5e2bbe2..b11b587fcfbe383ff360dce43f43c946ca14460f 100644 (file)
@@ -47,10 +47,10 @@ INITSCRIPT_PARAMS = "defaults"
 
 SYSTEMD_SERVICE_${PN} = "atd.service"
 
-
-do_compile_prepend () {
+copy_sources() {
        cp -f ${WORKDIR}/posixtm.[ch] ${S}
 }
+do_patch[postfuncs] += "copy_sources"
 
 do_install () {
        oe_runmake -e "IROOT=${D}" install