]> code.ossystems Code Review - openembedded-core.git/commitdiff
createrepo: drop the usage of create_wrapper
authorRoss Burton <ross.burton@intel.com>
Wed, 12 Jun 2013 16:29:21 +0000 (17:29 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 13 Jun 2013 16:37:58 +0000 (17:37 +0100)
create_wrapper was previously abused to invoke the Python interpretter directly
instead of relying on #! parsing, which is read into a 128 byte buffer so breaks
with deep build directories.

However now that we already install a "nativepython" binary into the native
sysroot, use sed to change the #! line to /usr/bin/env nativepython.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-support/createrepo/createrepo_0.4.11.bb

index c977c2e6e88c61a0d60899f70e2a4ca695c00c66..523d31b82aaabd27b3e716f78760b5c12ca7420a 100644 (file)
@@ -35,7 +35,7 @@ do_install_append_class-native () {
        for i in ${D}${datadir}/createrepo/genpkgmetadata.py \
                 ${D}${datadir}/createrepo/modifyrepo.py \
                 ${D}${bindir}/rpm-createsolvedb.py ; do
-               create_wrapper $i ${STAGING_BINDIR_NATIVE}/python-native/python
+               sed -i -e 's|^#!.*/usr/bin/env python|#! /usr/bin/env nativepython|' $i
        done
 
        create_wrapper ${D}/${bindir}/createrepo \