]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add a bit of a hack patch to disable frantic redrawing of GtkRange when they move...
authorRoss Burton <ross@openedhand.com>
Thu, 26 Jul 2007 16:12:11 +0000 (16:12 +0000)
committerRoss Burton <ross@openedhand.com>
Thu, 26 Jul 2007 16:12:11 +0000 (16:12 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2234 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/gtk+/gtk+-2.10.12/range-no-redraw.patch [new file with mode: 0644]
meta/packages/gtk+/gtk+-2.6.10/range-no-redraw.patch [new file with mode: 0644]
meta/packages/gtk+/gtk+_2.10.12.bb
meta/packages/gtk+/gtk+_2.6.10.bb

diff --git a/meta/packages/gtk+/gtk+-2.10.12/range-no-redraw.patch b/meta/packages/gtk+/gtk+-2.10.12/range-no-redraw.patch
new file mode 100644 (file)
index 0000000..384d71b
--- /dev/null
@@ -0,0 +1,17 @@
+Index: gtk/gtkrange.c
+===================================================================
+--- gtk/gtkrange.c     (revision 18523)
++++ gtk/gtkrange.c     (working copy)
+@@ -1979,8 +1979,12 @@
+       gtk_widget_queue_draw (GTK_WIDGET (range));
+       
+       /* This is so we don't lag the widget being scrolled. */
++#if 0
++      /* Disable this, the scroll bar lags a bit but the end result is that
++         scrolling treeviews is *a lot* smoother. See GNOME #460534. */
+       if (GTK_WIDGET_REALIZED (range))
+         gdk_window_process_updates (GTK_WIDGET (range)->window, FALSE);
++#endif
+     }
+   
+   /* Note that we don't round off to range->round_digits here.
diff --git a/meta/packages/gtk+/gtk+-2.6.10/range-no-redraw.patch b/meta/packages/gtk+/gtk+-2.6.10/range-no-redraw.patch
new file mode 100644 (file)
index 0000000..d168712
--- /dev/null
@@ -0,0 +1,18 @@
+Index: gtk/gtkrange.c
+===================================================================
+--- gtk/gtkrange.c     (revision 18542)
++++ gtk/gtkrange.c     (working copy)
+@@ -1569,9 +1569,12 @@
+   gtk_widget_queue_draw (GTK_WIDGET (range));
+   /* This is so we don't lag the widget being scrolled. */
++#if 0
++  /* Disable this, the scroll bar lags a bit but the end result is that
++     scrolling treeviews is *a lot* smoother. See GNOME #460534. */
+   if (GTK_WIDGET_REALIZED (range))
+     gdk_window_process_updates (GTK_WIDGET (range)->window, FALSE);
+-  
++#endif
+   /* Note that we don't round off to range->round_digits here.
+    * that's because it's really broken to change a value
+    * in response to a change signal on that value; round_digits
index 64241a79b1839206ddef9286511ec8191d5af576..0140286173af4413f256301e3c0bceec4c1a5878 100644 (file)
@@ -1,7 +1,7 @@
 require gtk+.inc
 
 DEPENDS += "cairo"
-PR = "r11"
+PR = "r12"
 
 # disable per default - untested and not all patches included.
 DEFAULT_PREFERENCE = "-1" 
@@ -23,6 +23,7 @@ SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.10/gtk+-${PV}.tar.bz2 \
         file://entry-cairo.patch;patch=1;pnum=0 \
         file://toggle-font.diff;patch=1;pnum=0 \
         file://combo-arrow-size.patch;patch=1;pnum=0 \
+        file://range-no-redraw.patch;patch=1;pnum=0 \
         file://scrolled-placement.patch;patch=1;pnum=0"
 #           file://scroll-timings.patch;patch=1 \
 #           file://pangoxft2.10.6.diff;patch=1"
index 0ec21848ff37c051be960151715cb022ec0212e8..d7199ef1dd19232b40d33298e8d9f40c0869cd2e 100644 (file)
@@ -1,6 +1,6 @@
 require gtk+.inc
 
-PR = "r11"
+PR = "r12"
 
 SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.6/gtk+-${PV}.tar.bz2 \
            file://no-demos.patch;patch=1 \
@@ -17,6 +17,7 @@ SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.6/gtk+-${PV}.tar.bz2 \
           file://filechooser-default.patch;patch=1 \
           file://toggle-font.diff;patch=1;pnum=0 \
           file://combo-arrow-size.patch;patch=1;pnum=0 \
+                  file://range-no-redraw.patch;patch=1;pnum=0 \
           "
 
 EXTRA_OECONF = "--without-libtiff --disable-xkb --disable-glibtest"