]> code.ossystems Code Review - openembedded-core.git/commitdiff
gpgme: Update to 1.3.0
authorZhai Edwin <edwin.zhai@intel.com>
Wed, 21 Jul 2010 07:06:16 +0000 (15:06 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Wed, 21 Jul 2010 15:00:58 +0000 (16:00 +0100)
gpgme 1.3.0 requires gpgconf&g13 from gnupg, otherwise got configure failure.
Adding gnupg need a lot of efforts and still has issue:g13 only exist in
development branch. So add a patch to disable the check error, just like
non-cross-compile environment.

Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
meta/packages/gpgme/gpgme-1.3.0/disable_gpgconf_check.patch [new file with mode: 0644]
meta/packages/gpgme/gpgme_1.3.0.bb [moved from meta/packages/gpgme/gpgme_1.1.4.bb with 55% similarity]

diff --git a/meta/packages/gpgme/gpgme-1.3.0/disable_gpgconf_check.patch b/meta/packages/gpgme/gpgme-1.3.0/disable_gpgconf_check.patch
new file mode 100644 (file)
index 0000000..f56f35b
--- /dev/null
@@ -0,0 +1,38 @@
+From 1.2.0, gpgme will check if gpgconf & g13(from 1.3.0) exist, and cause
+configure failure if not founding them in cross-compile environment. We can
+add the gnupg-native to get them, but still have some issues:
+
+1. need add new package: libksba, update libassuan(not in sato), and extend
+   native support in some other packages(libgcrypt, libgpg-error, pth...)
+2. Even we have gnupg, the g13 only exist in development branch, so that we
+   still have the g13 check failure in configure.
+
+I have searched the compile log, and found gpgconf/g13 are not used. So use a
+simple method here, throw a warning mesg rather than an error here just like in
+non-cross-compile environment.
+
+Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
+
+
+Index: gpgme-1.3.0/configure.ac
+===================================================================
+--- gpgme-1.3.0.orig/configure.ac      2010-07-21 09:38:09.000000000 +0800
++++ gpgme-1.3.0/configure.ac   2010-07-21 09:39:19.000000000 +0800
+@@ -574,7 +574,7 @@
+ *** Could not find gpgconf, install gpgconf or use --with-gpgconf=PATH to enable it
+ ***])
+     else
+-      AC_MSG_ERROR([
++      AC_MSG_WARN([
+ ***
+ *** Can not determine path to gpgconf when cross-compiling, use --with-gpgconf=PATH
+ ***])
+@@ -670,7 +670,7 @@
+ *** Could not find g13, install g13 or use --with-g13=PATH to enable it
+ ***])
+     else
+-      AC_MSG_ERROR([
++      AC_MSG_WARN([
+ ***
+ *** Can not determine path to g13 when cross-compiling, use --with-g13=PATH
+ ***])
similarity index 55%
rename from meta/packages/gpgme/gpgme_1.1.4.bb
rename to meta/packages/gpgme/gpgme_1.3.0.bb
index fa1632b94d1f2ebf0ca380d90530494cce22c5b0..1c665b5ea4ffbdf52e3b7063ba2e702828299b9e 100644 (file)
@@ -1,10 +1,17 @@
 DESCRIPTION = "GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications. It provides a High-Level Crypto API for encryption, decryption, signing, signature verification and key management"
 HOMEPAGE = "http://www.gnupg.org/gpgme.html"
+BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
+
 LICENSE = "GPLv2+ & LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
+                    file://COPYING.LESSER;md5=bbb461211a33b134d42ed5ee802b37ff \
+                    file://src/gpgme.h;endline=23;md5=2775a99d3dd524c4f848ff1c59093038 \
+                    file://src/engine.h;endline=22;md5=e96acfaab1cff82dd8fbefddd2f5c436"
 
-SRC_URI = "ftp://ftp.gnupg.org/gcrypt/gpgme/gpgme-${PV}.tar.bz2"
-DEPENDS = "libgpg-error pth"
-PR = "r4"
+SRC_URI = "ftp://ftp.gnupg.org/gcrypt/gpgme/gpgme-${PV}.tar.bz2 \
+           file://disable_gpgconf_check.patch;patch=1;pnum=1"
+DEPENDS = "libgpg-error libassuan pth"
+PR = "r0"
 
 EXTRA_OECONF = "--with-pth=${STAGING_DIR_HOST} --without-pth-test \
                 --with-gpg=${bindir}/gpg --without-gpgsm"