]> code.ossystems Code Review - openembedded-core.git/commitdiff
perl: native modules will not trigger build perl for target.
authorKrzysztof Taborski <taborskikrzysztof@gmail.com>
Tue, 8 May 2018 16:46:58 +0000 (18:46 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 11 May 2018 06:49:31 +0000 (07:49 +0100)
Currently building perl-native modules triggers
build perl for target due to PACKAGES_DYNAMIC regex.

This commit will cause, that perl native modules will
trigger perl-native build.

Signed-off-by: Krzysztof Taborski <taborskikrzysztof@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/perl/perl-native_5.24.1.bb
meta/recipes-devtools/perl/perl_5.24.1.bb

index a9ab17d16cf06f57d9ed75ce160bf7a6c239604c..71f45890b003bae91e78323cec88dd1be48e39ef 100644 (file)
@@ -135,3 +135,5 @@ EOF
 
 # Fix the path in sstate
 SSTATE_SCAN_FILES += "*.pm *.pod *.h *.pl *.sh"
+PACKAGES_DYNAMIC_class-native += "^perl-module-.*native$"
+
index 2574886784eab80c339b1709dbc6fa24a0ab9e61..1329a722408a4c6c2cc9515be8ff9e75c2f80a81 100644 (file)
@@ -340,7 +340,7 @@ python split_perl_packages () {
     d.setVar(d.expand("RRECOMMENDS_${PN}-modules"), ' '.join(packages))
 }
 
-PACKAGES_DYNAMIC += "^perl-module-.*"
+PACKAGES_DYNAMIC += "^perl-module-.*(?<!\-native)$"
 PACKAGES_DYNAMIC_class-nativesdk += "^nativesdk-perl-module-.*"
 
 RPROVIDES_perl-lib = "perl-lib"