]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto/4.12: ipv4 stable backport and config changes
authorBruce Ashfield <bruce.ashfield@windriver.com>
Thu, 21 Dec 2017 15:49:14 +0000 (10:49 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 21 Dec 2017 16:26:11 +0000 (16:26 +0000)
Integrating the following ipv4 backport:

    ipv4: net namespace does not inherit network configurations

    patch from https://lkml.org/lkml/2014/7/29/119

    Ipv4 net namespace requires a similar logic change as commit a79ca223e029
    [ipv6: fix bad free of addrconf_init_net] introduces for newer kernels.

    Since a net namespace is independent to another. That is, there
    is no any relationship between the net namespaces. So a new net
    namespace should not inherit network configurations from another
    net namespace including the host.

CC: Hong Zhiguo <honkiko@gmail.com>
CC: David S. Miller <davem@davemloft.net>
Signed-off-by: Zhu Yanjun <zyjzyj2000@gmail.com>
Signed-off-by: yzhu1 <yanjun.zhu@windriver.com>
Signed-off-by: Liwei Song <liwei.song@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
And the following configuration changes:

  3574bb061c1b mti-malta32: enable CONFIG_HIGHMEM for qemumips to support up to 2GiB RAM
  f187df8fca31 features/i915/i915.cfg: compile i915 as a module
  332b38cb83a2 common-pc*.scc: Add igb to common-pc drivers

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb
meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb
meta/recipes-kernel/linux/linux-yocto_4.12.bb

index adbb0ccbad5b226a065e2d88e66953902428d924..efa4f05bb0b69bf543bd6f682d84b30ecbde3051 100644 (file)
@@ -11,8 +11,8 @@ python () {
         raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
 }
 
-SRCREV_machine ?= "82dfc739621af193e6b5cb8f27f55c66db8e631b"
-SRCREV_meta ?= "e3c9041f48ae980cc4461f969d0e3ed9bb43be5b"
+SRCREV_machine ?= "51c45f6489df4cdbce78e9c90b8a26fa7e7c875c"
+SRCREV_meta ?= "3574bb061c1bfbdcf4df8308870c03f88ef0788f"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.12.git;branch=${KBRANCH};name=machine \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.12;destsuffix=${KMETA}"
index 4e18d413ce5da1200aa96716baac56a19679bb9f..78056ee831834246279e6dcdb3c2d3e47b89fdcf 100644 (file)
@@ -9,8 +9,8 @@ LINUX_VERSION ?= "4.12.16"
 KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "2"
 
-SRCREV_machine ?= "1d685baca196583254d75f5cc7bc0ffedb8753ad"
-SRCREV_meta ?= "e3c9041f48ae980cc4461f969d0e3ed9bb43be5b"
+SRCREV_machine ?= "4226b065fca4f630901d99b99d18c395ae3866fb"
+SRCREV_meta ?= "3574bb061c1bfbdcf4df8308870c03f88ef0788f"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
index 0df702e4703fd7e919e41eb41d097d836e9f641a..90a00a513dd69298bf2198bd207587625c4be351 100644 (file)
@@ -11,15 +11,15 @@ KBRANCH_qemux86  ?= "standard/base"
 KBRANCH_qemux86-64 ?= "standard/base"
 KBRANCH_qemumips64 ?= "standard/mti-malta64"
 
-SRCREV_machine_qemuarm ?= "9f857972035c7e3ae237d25a581eb695ffe78249"
-SRCREV_machine_qemuarm64 ?= "1d685baca196583254d75f5cc7bc0ffedb8753ad"
-SRCREV_machine_qemumips ?= "6527cf00278f043ba8f874ac7262261dd57e9a79"
-SRCREV_machine_qemuppc ?= "1d685baca196583254d75f5cc7bc0ffedb8753ad"
-SRCREV_machine_qemux86 ?= "1d685baca196583254d75f5cc7bc0ffedb8753ad"
-SRCREV_machine_qemux86-64 ?= "1d685baca196583254d75f5cc7bc0ffedb8753ad"
-SRCREV_machine_qemumips64 ?= "ad347d33914f66c4b2aa6fca0c9f0a92773885cc"
-SRCREV_machine ?= "1d685baca196583254d75f5cc7bc0ffedb8753ad"
-SRCREV_meta ?= "e3c9041f48ae980cc4461f969d0e3ed9bb43be5b"
+SRCREV_machine_qemuarm ?= "6227bf7bc958840e020930ac250634129919571b"
+SRCREV_machine_qemuarm64 ?= "4226b065fca4f630901d99b99d18c395ae3866fb"
+SRCREV_machine_qemumips ?= "16b69ee760d800e7f16a01476a24a87b66702dc6"
+SRCREV_machine_qemuppc ?= "4226b065fca4f630901d99b99d18c395ae3866fb"
+SRCREV_machine_qemux86 ?= "4226b065fca4f630901d99b99d18c395ae3866fb"
+SRCREV_machine_qemux86-64 ?= "4226b065fca4f630901d99b99d18c395ae3866fb"
+SRCREV_machine_qemumips64 ?= "4eb2f843b67a8e97619689991b566808212a3677"
+SRCREV_machine ?= "4226b065fca4f630901d99b99d18c395ae3866fb"
+SRCREV_meta ?= "3574bb061c1bfbdcf4df8308870c03f88ef0788f"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.12.git;name=machine;branch=${KBRANCH}; \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.12;destsuffix=${KMETA}"