]> code.ossystems Code Review - openembedded-core.git/commitdiff
perf: fix broken shell comparsion in do_install
authorHenning Heinold <henning@itconsulting-heinold.de>
Tue, 24 Jun 2014 21:34:45 +0000 (23:34 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 3 Jul 2014 12:44:53 +0000 (13:44 +0100)
The patch was sponsored by sysmocom

Signed-off-by: Henning Heinold <henning@itconsulting-heinold.de>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/perf/perf.bb

index 903ffa6eaff571939c8a79bd92b3a56fe95be952..31c2c8eade01b960fd9cc4c84f116811b8229273 100644 (file)
@@ -109,7 +109,7 @@ do_install() {
        unset CFLAGS
        oe_runmake DESTDIR=${D} install
        # we are checking for this make target to be compatible with older perf versions
-       if [ "${@perf_feature_enabled('perf-scripting', 1, 0, d)}" = "1" -a $(grep install-python_ext ${S}/tools/perf/Makefile) = "0"]; then
+       if [ "${@perf_feature_enabled('perf-scripting', 1, 0, d)}" = "1" -a $(grep install-python_ext ${S}/tools/perf/Makefile) = "0" ]; then
                oe_runmake DESTDIR=${D} install-python_ext
        fi
 }