]> code.ossystems Code Review - openembedded-core.git/commitdiff
opkg-utils: use D instead of OPKG_OFFLINE_ROOT in postrm
authorAndré Draszik <adraszik@tycoint.com>
Thu, 12 Jan 2017 10:42:25 +0000 (10:42 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 16 Jan 2017 18:01:57 +0000 (18:01 +0000)
While both result in the same in this case, postrm
should really be referring to $D as we do everywhere
else.

Signed-off-by: André Draszik <adraszik@tycoint.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/opkg-utils/opkg-utils_git.bb

index 094f4e75de066c3b34fd594cc44e8f7c4f12019f..7b3b86e1dcd781b8f5d10b0bf81aabcdad87f1e3 100644 (file)
@@ -46,8 +46,8 @@ RREPLACES_update-alternatives-opkg = "update-alternatives-cworth"
 RCONFLICTS_update-alternatives-opkg = "update-alternatives-cworth"
 
 pkg_postrm_update-alternatives-opkg() {
-       rm -rf $OPKG_OFFLINE_ROOT${nonarch_libdir}/opkg/alternatives
-       rmdir $OPKG_OFFLINE_ROOT${nonarch_libdir}/opkg || true
+       rm -rf $D${nonarch_libdir}/opkg/alternatives
+       rmdir $D${nonarch_libdir}/opkg || true
 }
 
 BBCLASSEXTEND = "native nativesdk"