]> code.ossystems Code Review - openembedded-core.git/commitdiff
dpkg: upgrade to 1.14.19
authorMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 19 Jun 2008 15:16:11 +0000 (15:16 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 19 Jun 2008 15:16:11 +0000 (15:16 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4709 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/dpkg/dpkg-native_1.14.19.bb [new file with mode: 0644]
meta/packages/dpkg/dpkg_1.14.19.bb [new file with mode: 0644]
meta/packages/dpkg/files/ignore_extra_fields.patch

diff --git a/meta/packages/dpkg/dpkg-native_1.14.19.bb b/meta/packages/dpkg/dpkg-native_1.14.19.bb
new file mode 100644 (file)
index 0000000..b21e95d
--- /dev/null
@@ -0,0 +1,13 @@
+require dpkg.inc
+DEPENDS += "ncurses-native bzip2-native zlib-native virtual/update-alternatives-native"
+SRC_URI += "file://noman.patch;patch=1"
+
+inherit native
+
+EXTRA_OECONF = "--without-static-progs \
+               --without-dselect \
+               --with-start-stop-daemon \
+               --with-zlib \
+               --with-bz2lib \
+                --without-selinux \
+               --without-sgml-doc"
diff --git a/meta/packages/dpkg/dpkg_1.14.19.bb b/meta/packages/dpkg/dpkg_1.14.19.bb
new file mode 100644 (file)
index 0000000..81415f6
--- /dev/null
@@ -0,0 +1,11 @@
+require dpkg.inc
+DEPENDS += "ncurses zlib bzip2"
+RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives}"
+SRC_URI += "file://noman.patch;patch=1"
+
+EXTRA_OECONF = "--without-static-progs \
+               --without-dselect \
+               --with-start-stop-daemon \
+               --with-zlib \
+               --with-bz2lib \
+               --without-sgml-doc"
index 43878463e936ed730aa5e26b87592c4e36d938e6..d09343c6e5fc4d1869e7c8a62b4a1fb9bb588c69 100644 (file)
@@ -1,16 +1,19 @@
  dpkg-deb/build.c |    4 ++--
  1 file changed, 2 insertions(+), 2 deletions(-)
 
-Index: dpkg-1.13.22/dpkg-deb/build.c
-===================================================================
---- dpkg-1.13.22.orig/dpkg-deb/build.c 2006-05-19 23:11:08.000000000 +0100
-+++ dpkg-1.13.22/dpkg-deb/build.c      2006-11-17 14:43:20.000000000 +0000
-@@ -220,11 +220,11 @@ void do_build(const char *const *argv) {
+--- dpkg-1.14.19.orig/dpkg-deb/build.c
++++ dpkg-1.14.19/dpkg-deb/build.c
+@@ -241,18 +241,18 @@ void do_build(const char *const *argv) {
+     if (checkedinfo->priority == pri_other) {
+       fprintf(stderr, _("warning, `%s' contains user-defined Priority value `%s'\n"),
                controlfile, checkedinfo->otherpriority);
        warns++;
      }
 -    for (field= checkedinfo->available.arbs; field; field= field->next) {
 +    /*for (field= checkedinfo->available.arbs; field; field= field->next) {
+       if (known_arbitrary_field(field))
+         continue;
        fprintf(stderr, _("warning, `%s' contains user-defined field `%s'\n"),
                controlfile, field->name);
        warns++;
@@ -19,3 +22,5 @@ Index: dpkg-1.13.22/dpkg-deb/build.c
      checkversion(checkedinfo->available.version.version,"(upstream) version",&errs);
      checkversion(checkedinfo->available.version.revision,"Debian revision",&errs);
      if (errs) ohshit(_("%d errors in control file"),errs);
+     if (subdir) {