]> code.ossystems Code Review - openembedded-core.git/commitdiff
task-base, task-poky-basic, task-poky: Remove hard-coded references to dropbear
authorScott Garman <scott.a.garman@intel.com>
Fri, 4 Mar 2011 22:03:02 +0000 (14:03 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 16 Mar 2011 13:43:15 +0000 (13:43 +0000)
This is the first step in refactoring the SSH server selection to
be done in IMAGE_FEATURES instead of as hardcoded in these tasks.

Signed-off-by: Scott Garman <scott.a.garman@intel.com>
meta/recipes-core/tasks/task-base.bb
meta/recipes-extended/tasks/task-poky-basic.bb
meta/recipes-sato/tasks/task-poky.bb

index d613bb2e90b2f3f1ed653f2c5048fe2364847227..138e617c9242f7e8cd93e0cad74b75dca1dccd34 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Merge machine and distro options to create a basic machine task/p
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${POKYBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
                     file://${POKYBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-PR = "r69"
+PR = "r70"
 
 inherit task
 
@@ -59,11 +59,6 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
 #
 HOTPLUG ?= "${@base_contains("MACHINE_FEATURES", "kernel24",  "linux-hotplug","",d)} "
 
-#
-# dropbear, openssh or none
-#
-DISTRO_SSH_DAEMON ?= "dropbear"
-
 #
 # pcmciautils for >= 2.6.13-rc1, pcmcia-cs for others
 #
@@ -81,7 +76,6 @@ MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS ?= ""
 RDEPENDS_task-base = "\
     task-distro-base \
     task-machine-base \
-    ${DISTRO_SSH_DAEMON} \
     ${HOTPLUG} \
     \
     ${@base_contains('MACHINE_FEATURES', 'kernel26','task-base-kernel26','task-base-kernel24',d)} \
index d7beafedd8653ccceabc4ba2abb45597dc85682d..3d313f0e52f39210d003191121bf92e62f17a694 100644 (file)
@@ -3,7 +3,7 @@
 #
 
 DESCRIPTION = "Create Basic Image Tasks"
-PR = "r2"
+PR = "r3"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${POKYBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
                     file://${POKYBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
@@ -55,7 +55,6 @@ RDEPENDS_task-poky-basic = "\
 
 RDEPENDS_task-poky-base-utils = "\
     busybox \
-    dropbear \
     "
 
 RDEPENDS_task-poky-basic-libs = "\
index cfcbacbf3978928a20d24d23d270fd76c009194c..72d4d0d9cbbc0b146057d6a6f5c28328b33fc118 100644 (file)
@@ -6,7 +6,7 @@ DESCRIPTION = "Tasks for OpenedHand Poky"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${POKYBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
                     file://${POKYBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-PR = "r33"
+PR = "r34"
 
 PACKAGES = "\
     task-poky-apps-console \
@@ -37,7 +37,6 @@ FILEMANAGER_mips ?= ""
 
 RDEPENDS_task-poky-apps-console = "\
     avahi-daemon \
-    dropbear \
     dbus \
     portmap \
     ${SPLASH}"