]> code.ossystems Code Review - openembedded-core.git/commitdiff
strace: remove += assignment of a OVERRIDES variable
authorMing Liu <ming.liu@windriver.com>
Mon, 21 Oct 2013 00:41:34 +0000 (08:41 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 30 Oct 2013 13:39:02 +0000 (13:39 +0000)
In some cases, it's unfit to use "+=" in a conditional appending, we would
end up with the variable being set rather than being appended, which is not
it mean to.

Signed-off-by: Ming Liu <ming.liu@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/strace/strace_4.8.bb

index 79a4ad79ab0711dfe9396543c1d1b71420308fcf..23cc03e8af7692c2dd653c1dd3d2b2e12130fc27 100644 (file)
@@ -18,8 +18,7 @@ SRC_URI[sha256sum] = "f492291f07a7c805c07a8395cce1ea054a6401ad414f4cc12185672215
 inherit autotools ptest
 RDEPENDS_${PN}-ptest += "make"
 
-PACKAGECONFIG_class-target ?= "libaio"
-PACKAGECONFIG_class-target += "${@base_contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}"
+PACKAGECONFIG_class-target ?= "libaio ${@base_contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}"
 
 PACKAGECONFIG[libaio] = "--enable-aio,--disable-aio,libaio"
 PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl"