]> code.ossystems Code Review - openembedded-core.git/commitdiff
ghostscript: Fix owner/group of /etc/cups
authorMark Hatle <mark.hatle@windriver.com>
Mon, 20 Jun 2011 18:18:19 +0000 (13:18 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 23 Jun 2011 20:01:48 +0000 (21:01 +0100)
/etc/cups is owned by root:lp from the cups package, the associated
ghostscript was creating the /etc/cups directory as root:root.  /etc/cups
is the authoritative source.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
meta/recipes-extended/ghostscript/ghostscript_9.02.bb

index 3cb5485d24e96b7ecb92fc0ed2a4620f4e555c21..02038ea632e55fc06c8b3532754b425bc2a49edc 100644 (file)
@@ -15,7 +15,7 @@ SECTION = "console/utils"
 LICENSE = "GPLv3"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=d151214b3131251dfc9d858593acbd24"
 
-PR = "r2"
+PR = "r3"
 
 DEPENDS = "${PN}-native tiff jpeg fontconfig cups"
 DEPENDS_virtclass-native = ""
@@ -57,6 +57,8 @@ do_install_append () {
     mkdir -p ${D}${datadir}/ghostscript/${PV}/
     cp -r Resource ${D}${datadir}/ghostscript/${PV}/
     cp -r iccprofiles ${D}${datadir}/ghostscript/${PV}/
+
+    chown -R root:lp ${D}${sysconfdir}/cups
 }
 
 python do_patch_virtclass-native () {