]> code.ossystems Code Review - openembedded-core.git/commitdiff
perf: fix python-audit RDEPENDS
authorBruce Ashfield <bruce.ashfield@gmail.com>
Mon, 3 May 2021 12:54:31 +0000 (08:54 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 4 May 2021 21:48:12 +0000 (22:48 +0100)
When doing the perf python3 conversion, the audit-python RDEPENDS
was caught up in the regex replacement and was incorrectly changed.

The audit recipe continues to produce a package called audit-python
and it is that package we should have as a RDEPENDS.

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/perf/perf.bb

index e5e5a0d2670f251a6ff146542d7422a6f46b0cda..2dfd798ef7d3861723166463a54bc0efac26d5cb 100644 (file)
@@ -322,7 +322,7 @@ PACKAGES =+ "${PN}-archive ${PN}-tests ${PN}-perl ${PN}-python"
 
 RDEPENDS_${PN} += "elfutils bash"
 RDEPENDS_${PN}-archive =+ "bash"
-RDEPENDS_${PN}-python =+ "bash python3 python3-modules ${@bb.utils.contains('PACKAGECONFIG', 'audit', 'audit-python3', '', d)}"
+RDEPENDS_${PN}-python =+ "bash python3 python3-modules ${@bb.utils.contains('PACKAGECONFIG', 'audit', 'audit-python', '', d)}"
 RDEPENDS_${PN}-perl =+ "bash perl perl-modules"
 RDEPENDS_${PN}-tests =+ "python3 bash"