]> code.ossystems Code Review - openembedded-core.git/commitdiff
gupnp: Convert to new staging method
authorRichard Purdie <rpurdie@linux.intel.com>
Mon, 16 Nov 2009 22:51:51 +0000 (22:51 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Mon, 16 Nov 2009 22:51:51 +0000 (22:51 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/gupnp/gupnp_0.12.5.bb

index 4fd75d8932c1bcb90f9ff23f6c04cb6ed6275601..a19bbce0ac6ad4e2916b4f63be66cee0d4e4191a 100644 (file)
@@ -9,6 +9,9 @@ inherit autotools_stage pkgconfig
 FILES_${PN} = "${libdir}/*.so.*"
 FILES_${PN}-dev += "${bindir}/gupnp-binding-tool"
 
-do_stage_append () {
-       install ${S}/tools/gupnp-binding-tool ${STAGING_BINDIR_NATIVE}
-}
\ No newline at end of file
+SYSROOT_PREPROCESS_FUNCS += "gupnp_sysroot_preprocess"
+
+gupnp_sysroot_preprocess () {
+       install -d ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/
+       install -m 755 ${bindir}/gupnp-binding-tool ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/
+}