]> code.ossystems Code Review - openembedded-core.git/commitdiff
libx11: update to 1.6.7 and sytle cleanup
authorArmin Kuster <akuster808@gmail.com>
Sat, 20 Oct 2018 17:02:55 +0000 (18:02 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 9 Nov 2018 17:47:11 +0000 (17:47 +0000)
refresh Fix-hanging-issue-in-_XReply.patch

Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-graphics/xorg-lib/libx11/Fix-hanging-issue-in-_XReply.patch
meta/recipes-graphics/xorg-lib/libx11_1.6.7.bb [moved from meta/recipes-graphics/xorg-lib/libx11_1.6.6.bb with 64% similarity]

index 897882b8d8cb5168cd91ea3ae51034942a7d6464..2a723b7e43d13f46c097516a7067dba16c8b0e32 100644 (file)
@@ -17,19 +17,19 @@ https://patchwork.freedesktop.org/patch/171458/
 
 Signed-off-by: Tatu Frisk <tatu.frisk@ge.com>
 Signed-off-by: Jose Alarcon <jose.alarcon@ge.com>
+
+[Refreshed for 1.6.7 update]
+Signed-off-by: Armin Kuster <akuster808@gmail.com>
+
 ---
  src/xcb_io.c | 19 +++++++------------
  1 file changed, 7 insertions(+), 12 deletions(-)
 
-diff --git a/src/xcb_io.c b/src/xcb_io.c
-index 5987329..c64eb04 100644
---- a/src/xcb_io.c
-+++ b/src/xcb_io.c
-@@ -609,22 +609,17 @@ Status _XReply(Display *dpy, xReply *rep, int extra, Bool discard)
-                * letting anyone else process this sequence number, we
-                * need to process any events that should have come
-                * earlier. */
--
+Index: libX11-1.6.7/src/xcb_io.c
+===================================================================
+--- libX11-1.6.7.orig/src/xcb_io.c
++++ libX11-1.6.7/src/xcb_io.c
+@@ -620,18 +620,14 @@ Status _XReply(Display *dpy, xReply *rep
                if(dpy->xcb->event_owner == XlibOwnsEventQueue)
                {
                        xcb_generic_reply_t *event;
@@ -42,6 +42,9 @@ index 5987329..c64eb04 100644
 -                      while(dpy->xcb->event_waiter)
 -                      { /* need braces around ConditionWait */
 -                              ConditionWait(dpy, dpy->xcb->event_notify);
+-                      }
+-                      while((event = poll_for_event(dpy, True)))
+-                              handle_response(dpy, event, True);
 +
 +                      /* Assume event queue is empty if another thread is blocking
 +                       * waiting for event. */
@@ -49,12 +52,7 @@ index 5987329..c64eb04 100644
 +                      {
 +                              while((event = poll_for_response(dpy)))
 +                                      handle_response(dpy, event, True);
-                       }
--                      while((event = poll_for_event(dpy)))
--                              handle_response(dpy, event, True);
++                        }
                }
  
                req->reply_waiter = 0;
--- 
-2.10.1
-
similarity index 64%
rename from meta/recipes-graphics/xorg-lib/libx11_1.6.6.bb
rename to meta/recipes-graphics/xorg-lib/libx11_1.6.7.bb
index 0fee1a90891ec73a865dc675d55c9ae606a17569..f0f1bfd34163df6cc45476d5efa2527b397efe5f 100644 (file)
@@ -1,14 +1,16 @@
 require libx11.inc
-inherit gettext
 
-BBCLASSEXTEND = "native nativesdk"
+SRC_URI[md5sum] = "034fdd6cc5393974d88aec6f5bc96162"
+SRC_URI[sha256sum] = "910e9e30efba4ad3672ca277741c2728aebffa7bc526f04dcfa74df2e52a1348"
 
 SRC_URI += "file://disable_tests.patch \
             file://Fix-hanging-issue-in-_XReply.patch \
            "
+
+inherit gettext
+
 do_configure_append () {
     sed -i -e "/X11_CFLAGS/d" ${B}/src/util/Makefile
 }
 
-SRC_URI[md5sum] = "6b0f83e851b3b469dd660f3a95ac3e42"
-SRC_URI[sha256sum] = "65fe181d40ec77f45417710c6a67431814ab252d21c2e85c75dd1ed568af414f"
+BBCLASSEXTEND = "native nativesdk"