]> code.ossystems Code Review - openembedded-core.git/commitdiff
quilt: Export QUILT_PC variable in ptest Makefile
authorTrevor Gamblin <trevor.gamblin@windriver.com>
Thu, 22 Aug 2019 12:29:04 +0000 (08:29 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 22 Aug 2019 16:36:13 +0000 (17:36 +0100)
The quilt ptest uses a custom Makefile to implement the
"make check" rule, but the ptest Makefile does not export
the variable QUILT_PC, which is user-settable and normally
defaults to ".pc". This causes failures e.g. import.test
with "rm -rf patches/ %{QUILT_PC}/", evaluating to
"rm -rf patches/ /" if the variable is not set by the
Makefile.

These ptests broke in:
  73d6034f6b quilt: update to 0.66
when the upstream quilt developers enabled users to specify
their own QUILT_PC string.

Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/quilt/quilt/Makefile

index 7b3ac8a49291ba3e403d56007bd20f501f53ddd1..1f6cd2479caf2b60cf384688049109c640747f0e 100644 (file)
@@ -2,7 +2,8 @@ PATH :=         $(CURDIR)/bin:$(CURDIR)/compat:$(PATH)
 QUILT_DIR :=    $(CURDIR)/quilt
 QUILTRC :=      $(CURDIR)/test/test.quiltrc
 export QUILT_DIR QUILTRC
-CHECK_ENV := P=patches/; _P=../patches/; export P _P
+CHECK_ENV := P=patches/; _P=../patches/; export P _P;
+CHECK_ENV += QUILT_PC=.pc; export QUILT_PC
 -include test/.depend
 
 check-% : test/%.test