]> code.ossystems Code Review - openembedded-core.git/commitdiff
libpcre: Clean up FILES_* after PACKAGES reoder
authorSaul Wold <sgw@linux.intel.com>
Tue, 19 Jun 2012 15:41:08 +0000 (08:41 -0700)
committerSaul Wold <sgw@linux.intel.com>
Wed, 20 Jun 2012 04:59:54 +0000 (21:59 -0700)
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-support/libpcre/libpcre_8.30.bb

index 83831e7830240e89af07a7b9f6c993eb42148010..05ca7ca4e551106ee99aaa3c9733c8fd156d618e 100644 (file)
@@ -5,7 +5,7 @@ provides a POSIX calling interface to PCRE; the regular expressions \
 themselves still follow Perl syntax and semantics. The header file for \
 the POSIX-style functions is called pcreposix.h."
 SECTION = "devel"
-PR = "r0"
+PR = "r1"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://LICENCE;md5=115e2bee152e2e23e838a29136094877"
 SRC_URI = "${SOURCEFORGE_MIRROR}/project/pcre/pcre/${PV}/pcre-${PV}.tar.bz2 \
@@ -47,10 +47,7 @@ do_compile () {
 
 python populate_packages_prepend () {
        pcre_libdir = d.expand('${libdir}')
-       do_split_packages(d, pcre_libdir, '^lib(.*)\.so\.+', 'lib%s', 'libpcre %s library', extra_depends='', allow_links=True)
+       do_split_packages(d, pcre_libdir, '^lib(.*)\.so\.+', 'lib%s', 'libpcre %s library', extra_depends='', allow_links=True, prepend=True)
 }
 
-FILES_${PN} = "${libdir}/libpcre.so.*"
-FILES_${PN}-dev += "${bindir}/*"
-
 BBCLASSEXTEND = "native"