]> code.ossystems Code Review - openembedded-core.git/commitdiff
kmscube: make gstreamer dependency optional
authorAlexander Kanavin <alex.kanavin@gmail.com>
Wed, 23 Jan 2019 16:17:42 +0000 (17:17 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 24 Jan 2019 17:45:28 +0000 (17:45 +0000)
This in particular saves build times for virgl oe-selftest.

Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/kmscube/kmscube_git.bb

index c6cb1842158d604df06873e4ebc80c4ecd63d1a4..b2dd6b30b0ebfacb7ae7c8636c19b9d0939cc148 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Demo application to showcase 3D graphics using kms and gbm"
 HOMEPAGE = "https://cgit.freedesktop.org/mesa/kmscube/"
 LICENSE = "MIT"
 SECTION = "graphics"
-DEPENDS = "virtual/libgles2 virtual/egl libdrm gstreamer1.0 gstreamer1.0-plugins-base"
+DEPENDS = "virtual/libgles2 virtual/egl libdrm"
 
 LIC_FILES_CHKSUM = "file://kmscube.c;beginline=1;endline=23;md5=8b309d4ee67b7315ff7381270dd631fb"
 
@@ -16,3 +16,6 @@ S = "${WORKDIR}/git"
 inherit meson pkgconfig distro_features_check
 
 REQUIRED_DISTRO_FEATURES = "opengl"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[gstreamer] = "-Dgstreamer=enabled,-Dgstreamer=disabled,gstreamer1.0 gstreamer1.0-plugins-base"