]> code.ossystems Code Review - openembedded-core.git/commitdiff
valgrind: Disable leak_cpp_interior test
authorKhem Raj <raj.khem@gmail.com>
Sat, 1 May 2021 17:46:58 +0000 (10:46 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 2 May 2021 22:21:39 +0000 (23:21 +0100)
This test is known to fail and especially is prominent with GCC-11
where stdc++17 is enabled by default

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/valgrind/valgrind_3.17.0.bb

index 4eb948f2db246f4121789479c637e8e40ab7faa2..ebbd83dd3f4986a68997075922238009217b7321 100644 (file)
@@ -233,6 +233,9 @@ do_install_ptest() {
     # https://bugs.kde.org/show_bug.cgi?id=402833
     rm ${D}${PTEST_PATH}/memcheck/tests/overlap.vgtest
 
+    # This is known failure see https://bugs.kde.org/show_bug.cgi?id=435732
+    rm ${D}${PTEST_PATH}/memcheck/tests/leak_cpp_interior.vgtest
+
     # As the binary isn't stripped or debug-splitted, the source file isn't fetched
     # via dwarfsrcfiles either, so it needs to be installed manually.
     mkdir -p ${D}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/${BP}/none/tests/