]> code.ossystems Code Review - openembedded-core.git/commitdiff
lttng/perf: depend on virtual/kernel:do_install
authorBruce Ashfield <bruce.ashfield@windriver.com>
Thu, 4 Dec 2014 04:14:08 +0000 (23:14 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 20 Dec 2014 11:24:04 +0000 (11:24 +0000)
To ensure that the minimal environment has been created for out of
tree module builds, perf and lttng should depend on the do_install
task of the kernel.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
meta/recipes-kernel/lttng/lttng-modules_2.5.0.bb
meta/recipes-kernel/perf/perf.bb

index 6ff961a9b189f186f04a396a6f7c00d36e88b689..f66118011afec9a044aa3b77360a005dcd36aead 100644 (file)
@@ -7,6 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=1412caf5a1aa90d6a48588a4794c0eac \
                     file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad"
 
 DEPENDS = "virtual/kernel"
+do_configure[depends] += "virtual/kernel:do_install"
 
 inherit module
 
index d375e246ce302c2751d51f2bc027091eb191b98f..a42aa73c53c96f7217177f1a2e232fd306fb98bc 100644 (file)
@@ -32,7 +32,7 @@ DEPENDS = " \
     bison flex \
 "
 
-do_configure[depends] += "virtual/kernel:do_patch"
+do_configure[depends] += "virtual/kernel:do_install"
 
 PROVIDES = "virtual/perf"