]> code.ossystems Code Review - openembedded-core.git/commitdiff
glib-networking: add PACKAGECONFIG for openssl
authorMartin Jansa <martin.jansa@gmail.com>
Fri, 10 May 2019 21:55:00 +0000 (21:55 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 27 May 2019 16:06:27 +0000 (17:06 +0100)
* gnutls from meta-gplv2 isn't new enough for this version of glib-networking:
  meson.build:74:0: ERROR:  Invalid version of dependency, need 'gnutls' ['>= 3.4.6'] found '3.3.30'

* disabling gnutls PACKAGECONFIG isn't an option either:
  meson.build:131:2: ERROR:  Problem encountered: No TLS backends enabled. Please enable at least one TLS backend

* add an option to replace gnutls with openssl

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/glib-networking/glib-networking_2.60.2.bb

index e0910de32e2e7d6753856f59f98f998135168df8..4d4fe649166b97e966b704286dbd093230dcb117 100644 (file)
@@ -15,6 +15,7 @@ SRC_URI[archive.sha256sum] = "c022f3d10f55a5b7c31676fb001b4cb6401db8ab9f6e8418c6
 PACKAGECONFIG ??= "gnutls"
 
 PACKAGECONFIG[gnutls] = "-Dgnutls=enabled,-Dgnutls=disabled,gnutls"
+PACKAGECONFIG[openssl] = "-Dopenssl=enabled,-Dopenssl=disabled,openssl"
 PACKAGECONFIG[libproxy] = "-Dlibproxy=enabled,-Dlibproxy=disabled,libproxy"
 
 EXTRA_OEMESON = "-Dgnome_proxy=disabled"