]> code.ossystems Code Review - openembedded-core.git/commitdiff
which: Add new recipe
authorDongxiao Xu <dongxiao.xu@intel.com>
Wed, 4 Aug 2010 02:32:04 +0000 (10:32 +0800)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 13 Aug 2010 12:35:59 +0000 (13:35 +0100)
Add which-2.20, which is licensed under GPLv3.

The installation will override the busybox "which" command.

Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
meta/packages/which/which-2.20/remove-declaration.patch [new file with mode: 0644]
meta/packages/which/which_2.20.bb [new file with mode: 0644]

diff --git a/meta/packages/which/which-2.20/remove-declaration.patch b/meta/packages/which/which-2.20/remove-declaration.patch
new file mode 100644 (file)
index 0000000..09b8143
--- /dev/null
@@ -0,0 +1,16 @@
+Remove the declaration of group_member since it has already been
+declared in unistd.h
+
+Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
+
+diff -ruN which-2.20-orig/bash.c which-2.20/bash.c
+--- which-2.20-orig/bash.c     2010-08-03 12:59:08.897088878 +0800
++++ which-2.20/bash.c  2010-08-03 13:17:23.406097212 +0800
+@@ -46,7 +46,6 @@
+  * - changed all occurences of 'gid_t' into 'GID_T'.
+  * - exported functions needed in which.c
+  */
+-static int group_member (GID_T gid);
+ static char* extract_colon_unit (char const* string, int* p_index);
+ /*===========================================================================
diff --git a/meta/packages/which/which_2.20.bb b/meta/packages/which/which_2.20.bb
new file mode 100644 (file)
index 0000000..b7730de
--- /dev/null
@@ -0,0 +1,35 @@
+DESCRIPTION = "which - shows the full path of (shell) commands."
+SECTION     = "libs"
+LICENSE = "GPLv3+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504\
+                    file://which.c;beginline=1;endline=17;md5=a9963693af2272e7a8df6f231164e7a2"
+HOMEPAGE = "http://ftp.gnu.org/gnu/which/"
+DEPENDS     = "cwautomacros-native"
+
+inherit autotools
+
+PR = "r0"
+
+SRC_URI = "http://ftp.gnu.org/gnu/which/which-${PV}.tar.gz \
+           file://remove-declaration.patch"
+
+do_configure_prepend() {
+       sed -i -e 's%@ACLOCAL_CWFLAGS@%-I ${STAGING_DIR_NATIVE}/usr/share/cwautomacros/m4%g' ${S}/Makefile.am ${S}/tilde/Makefile.am
+}
+
+do_install() {
+       autotools_do_install
+       mv ${D}${bindir}/which ${D}${bindir}/which.${PN}
+}
+
+pkg_postinst_${PN} () {
+        if [ "${PN}" = "${BPN}" ] ; then
+                update-alternatives --install ${bindir}/which which which.${PN} 100
+        fi
+}
+
+pkg_prerm_${PN} () {
+       if [ "${PN}" = "${BPN}" ] ; then
+               update-alternatives --remove which which.${PN}
+       fi
+}