]> code.ossystems Code Review - openembedded-core.git/commitdiff
e2fsprogs: Remove all mention of anything associated with uuids
authorJeff Dike <jdike@linux.intel.com>
Thu, 3 Jun 2010 19:27:30 +0000 (15:27 -0400)
committerRichard Purdie <rpurdie@linux.intel.com>
Mon, 7 Jun 2010 15:04:00 +0000 (16:04 +0100)
--disable-libuuid is added to the configure command line.  This has
the effect of disabling the compilation of uuidgen and libuuid.so.

These two are specified as making up their own packages, which turn
out to be empty, and thus aren't created in the first place.  The
error which manifests itself is at the final creation of the rootfs
when the global package depends on the e2fsprogs-uuidgen and libuuid,
which turn out not to exist, because they weren't created.

Signed-off-by: Jeff Dike <jdike@linux.intel.com>
meta/packages/e2fsprogs/e2fsprogs_1.41.12.bb

index 5360243f16608bc6124ca0d0030fe45b9ac0d0c6..15c80478f5965ed96502b7d63b0bbb49241b0a53 100644 (file)
@@ -1,6 +1,6 @@
 require e2fsprogs.inc
 
-PR = "r18"
+PR = "r19"
 
 SRC_URI += "file://quotefix.patch;patch=1 \
             file://acinclude.m4"
@@ -33,16 +33,14 @@ do_install () {
 # blkid used to be part of e2fsprogs but is useful outside, add it
 # as an RDEPENDS so that anything relying on it being in e2fsprogs
 # still works
-RDEPENDS_e2fsprogs = "e2fsprogs-blkid e2fsprogs-uuidgen e2fsprogs-badblocks"
+RDEPENDS_e2fsprogs = "e2fsprogs-blkid e2fsprogs-badblocks"
 
-PACKAGES =+ "e2fsprogs-blkid e2fsprogs-uuidgen e2fsprogs-e2fsck e2fsprogs-mke2fs e2fsprogs-fsck e2fsprogs-tune2fs e2fsprogs-badblocks libuuid"
+PACKAGES =+ "e2fsprogs-blkid e2fsprogs-e2fsck e2fsprogs-mke2fs e2fsprogs-fsck e2fsprogs-tune2fs e2fsprogs-badblocks"
 FILES_e2fsprogs-blkid = "${base_sbindir}/blkid"
-FILES_e2fsprogs-uuidgen = "${bindir}/uuidgen"
 FILES_e2fsprogs-fsck = "${base_sbindir}/fsck"
 FILES_e2fsprogs-e2fsck = "${base_sbindir}/e2fsck ${base_sbindir}/fsck.ext*"
 FILES_e2fsprogs-mke2fs = "${base_sbindir}/mke2fs ${base_sbindir}/mkfs.ext*"
 FILES_e2fsprogs-tune2fs = "${base_sbindir}/tune2fs ${base_sbindir}/e2label ${base_sbindir}/findfs"
 FILES_e2fsprogs-badblocks = "${base_sbindir}/badblocks"
-FILES_libuuid = "${libdir}/libuuid.so.*"
 
 BBCLASSEXTEND = "native"