]> code.ossystems Code Review - openembedded-core.git/commitdiff
libwpe: remove rpi-specific custom code
authorDenys Dmytriyenko <denis@denix.org>
Wed, 4 Aug 2021 01:34:16 +0000 (21:34 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 4 Aug 2021 19:41:45 +0000 (20:41 +0100)
This recipe was ported from another layer, which had special handling for rpi.

OE-Core doesn't have 'rpi' override, doesn't define 'vc4graphics' DISTRO_FEATURES
and overall, BSP-specifics should be handled in downstream layers, not in OE-Core.

Signed-off-by: Denys Dmytriyenko <denis@denix.org>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-sato/webkit/libwpe_1.10.1.bb

index 22fff93cab7bddc3ff9c4d68995b021f90b980e6..6f2fe1df423cf2d09ef9f52956576be669975999 100644 (file)
@@ -6,9 +6,6 @@ LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://COPYING;md5=371a616eb4903c6cb79e9893a5f615cc"
 DEPENDS = "virtual/egl libxkbcommon"
 
-# Workaround build issue with RPi userland EGL libraries.
-CFLAGS:append_rpi = " ${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', '-D_GNU_SOURCE', d)}"
-
 inherit cmake features_check
 
 REQUIRED_DISTRO_FEATURES = "opengl"