]> code.ossystems Code Review - openembedded-core.git/commitdiff
grub: Move grub-editenv packaging to grub2.inc
authorOtavio Salvador <otavio@ossystems.com.br>
Tue, 23 Jan 2018 16:56:25 +0000 (14:56 -0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 29 Jan 2018 08:43:37 +0000 (08:43 +0000)
The editenv utility must be available on grub and grub-efi so we
better have it inside the grub2.inc file to avoid the duplication of
metadata.

Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Ross Burton <ross.burton@intel.com>
(cherry picked from commit ebdd054ad85b19d47dd20eab0ba3f31ef5141140)
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-bsp/grub/grub2.inc
meta/recipes-bsp/grub/grub_2.02.bb

index a56fbe7bf8c331c5444a3bd0a65c2b9f32bc4057..28f96bb16223c56f6c77563d1578981ecb1b7025 100644 (file)
@@ -70,3 +70,9 @@ do_configure_prepend() {
 # grub and grub-efi's sysroot/${datadir}/grub/grub-mkconfig_lib are
 # conflicted, remove it since no one uses it.
 SYSROOT_DIRS_BLACKLIST += "${datadir}/grub/grub-mkconfig_lib"
+
+PACKAGES =+ "${PN}-editenv"
+
+FILES_${PN}-editenv = "${bindir}/grub-editenv"
+RDEPENDS_${PN} += "${PN}-editenv"
+RDEPENDS_${PN}_class-native = ""
index b8055e7537bba9fdb0bae4f2bf8e43ab159efd19..3e61f6a16d03277b308d04e2b2d4e4a2480807b4 100644 (file)
@@ -1,10 +1,6 @@
 require grub2.inc
 
-RDEPENDS_${PN} = "diffutils freetype grub-editenv"
-
-PACKAGES =+ "grub-editenv"
-
-FILES_grub-editenv = "${bindir}/grub-editenv"
+RDEPENDS_${PN} += "diffutils freetype"
 
 do_install_append () {
     install -d ${D}${sysconfdir}/grub.d