]> code.ossystems Code Review - openembedded-core.git/commitdiff
liberation-fonts: Added version 1.06, PREFERRED_VERSION is still 1.04
authorSaul Wold <Saul.Wold@intel.com>
Wed, 24 Nov 2010 20:32:58 +0000 (12:32 -0800)
committerSaul Wold <Saul.Wold@intel.com>
Wed, 24 Nov 2010 21:25:21 +0000 (13:25 -0800)
The new recipe requires fontforge, which is not added yet,
so the preferred version remains 1.04, when we have fontforge native
then we can remove this.

Signed-off-by: Saul Wold <Saul.Wold@intel.com>
meta/conf/distro/include/poky-fixed-revisions.inc
meta/recipes-graphics/ttf-fonts/liberation-fonts_1.06.bb [new file with mode: 0644]

index 23c34b5966797d8f200ed9182dad301372fc281e..0eb2af4885746c65934fc8588da8fd23cfe39d1d 100644 (file)
@@ -13,6 +13,9 @@ PYTHON_BASEVERSION ?= "2.6"
 PREFERRED_VERSION_python ?= "2.6.6"
 PREFERRED_VERSION_python-native ?= "2.6.6"
 
+# Force the older version of liberation-fonts until we fix the fontforge issue
+PREFERRED_VERSION_liberation-fonts ?= "1.04"
+
 
 
 
diff --git a/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.06.bb b/meta/recipes-graphics/ttf-fonts/liberation-fonts_1.06.bb
new file mode 100644 (file)
index 0000000..210372b
--- /dev/null
@@ -0,0 +1,39 @@
+DESCRIPTION = "The Liberation(tm) Fonts is a font family originally created by Ascender(c) which aims metric compatibility as usage of Arial, Times New Roman, Courier New"
+HOMEPAGE = "https://fedorahosted.org/liberation-fonts/"
+BUGTRACKER = "https://bugzilla.redhat.com/"
+
+SECTION = "x11/fonts"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+PACKAGE_ARCH = "all"
+RDEPENDS = "fontconfig-utils"
+PE = "1"
+PR = "r0"
+
+FONTREV = "0.20100721"
+SRC_URI = "https://fedorahosted.org/releases/l/i/${PN}/${PN}-${PV}.${FONTREV}.tar.gz \
+           file://30-liberation-aliases.conf"
+
+S = ${WORKDIR}/${PN}-${PV}.${FONTREV}
+
+do_install () {
+       install -d ${D}${datadir}/fonts/ttf/
+       for i in *.ttf; do
+               install -m 0644 $i ${D}${prefix}/share/fonts/ttf/${i}
+       done
+
+       install -d ${D}${sysconfdir}/fonts/conf.d/
+       install -m 0644 ${WORKDIR}/30-liberation-aliases.conf ${D}${sysconfdir}/fonts/conf.d/
+
+       install -d ${D}${prefix}/share/doc/${PN}/
+       install -m 0644 License.txt ${D}${datadir}/doc/${PN}/
+}
+
+pkg_postinst () {
+#!/bin/sh
+fc-cache
+}
+
+PACKAGES = "${PN}"
+FILES_${PN} += "${sysconfdir} ${datadir}"