]> code.ossystems Code Review - openembedded-core.git/commitdiff
glib-2.0: fix qsort_t testing for uclibc
authorHenning Heinold <heinold@inf.fu-berlin.de>
Fri, 18 Nov 2011 11:59:48 +0000 (12:59 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 18 Nov 2011 12:25:46 +0000 (12:25 +0000)
* instead of disabling the configure test and set it always true
  use the site files to set it true for glibc/eglibc and false
  for uclibc
* remove the patch
' tested only for uclibc
* bump PR

Signed-off-by: Henning Heinold <heinold@inf.fu-berlin.de>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/glib-2.0/glib-2.0/remove.test.for.qsort_r.patch [deleted file]
meta/recipes-core/glib-2.0/glib-2.0_2.30.0.bb
meta/site/common-glibc
meta/site/common-uclibc

diff --git a/meta/recipes-core/glib-2.0/glib-2.0/remove.test.for.qsort_r.patch b/meta/recipes-core/glib-2.0/glib-2.0/remove.test.for.qsort_r.patch
deleted file mode 100644 (file)
index 5c0a07a..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-while cross compiling we cannot execute run tests
-
-Upstream-Status: Inappropriate [configuration]
-
---- glib-2.30.0.orig/configure.ac      2011-09-29 16:57:35.000000000 +0200
-+++ glib-2.30.0/configure.ac   2011-09-29 17:00:19.931493488 +0200
-@@ -586,45 +586,7 @@
- dnl until we have checked this function is actually usable
- AC_CHECK_FUNC([qsort_r])
--# BSD has a qsort_r with wrong argument order
--if test x$ac_cv_func_qsort_r = xyes ; then
--  AC_CACHE_CHECK([if qsort_r uses glibc compatible argument order], glib_cv_have_qsort_r, [
--  AC_RUN_IFELSE([AC_LANG_SOURCE([[
--  #define _GNU_SOURCE
--  #include <stdlib.h>
--
--  static int
--  cmp (const void *a, const void *b, void *c)
--  {
--    const int *ia = a;
--    const int *ib = b;
--
--    if (*ia < *ib)
--      return -1;
--    else if (*ia > *ib)
--      return 1;
--    else
--      return 0;
--  }
--
--  int
--  main (int argc, char **argv)
--  {
--    int arr[3] = { 1, 2, 0 };
--    int d = 3;
--
--    qsort_r (arr, 3, sizeof (int), cmp, &d);
--
--    if (arr[0] == 0 && arr[1] == 1 && arr[2] == 2)
--      return 0;
--    else
--      return 1;
--  }]])],[glib_cv_have_qsort_r=yes],[glib_cv_have_qsort_r=no])])
--fi
--
--if test x$glib_cv_have_qsort_r = xyes ; then
--  AC_DEFINE(HAVE_QSORT_R, 1, [Define to 1 if you have the 'qsort_r' function])
--fi
-+AC_DEFINE(HAVE_QSORT_R, 1, [Define to 1 if you have the 'qsort_r' function])
- AC_CHECK_SIZEOF(char)
- AC_CHECK_SIZEOF(short)
index 634a4e4f4a83b9ded78dead93cc5477caa09eada..50e174e330df5d0077554d74405848448351fc0c 100644 (file)
@@ -1,6 +1,6 @@
 require glib.inc
 
-PR = "r3"
+PR = "r4"
 PE = "1"
 
 DEPENDS += "libffi python-argparse-native"
@@ -9,14 +9,10 @@ DEPENDS_virtclass-nativesdk += "libffi-nativesdk python-argparse-native zlib-nat
 
 SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
 
-QSORT_PATCH = "file://remove.test.for.qsort_r.patch"
-QSORT_PATCH_virtclass-native = ""
-
 SRC_URI = "${GNOME_MIRROR}/glib/${SHRT_VER}/glib-${PV}.tar.bz2 \
            file://configure-libtool.patch \
            file://60_wait-longer-for-threads-to-die.patch \
            file://g_once_init_enter.patch \
-           ${QSORT_PATCH} \
           "
 SRC_URI[md5sum] = "fee101d9d7daa8ddfbae00325f307f3b"
 SRC_URI[sha256sum] = "ca9c731017ab370859e847f8b70079bc6dcf389dc0ccb0d0419925aff81b9687"
index 364ab67d78b067dbdf5d493d87fbf790354d145f..dc69703eec15a4bd6fc34152dabadb39aeb02419 100644 (file)
@@ -39,6 +39,7 @@ glib_cv_long_long_format=${glib_cv_long_long_format=ll}
 # that to avoid a dependency loop.
 glib_cv___va_copy=${glib_cv___va_copy=yes}
 glib_cv_va_copy=${glib_cv_va_copy=yes}
+glib_cv_have_qsort_r=${glib_cv_have_qsort_r=yes}
 
 #dbus-glib
 ac_cv_have_abstract_sockets=${ac_cv_have_abstract_sockets=yes}
index a264765e871df34226ee296831dbf8e22635cf58..331c2a2773a8f0c3cd2a14a0e7547f2e322da44e 100644 (file)
@@ -20,6 +20,7 @@ ac_cv_func_snprintf_c99=${ac_cv_func_snprintf_c99=yes}
 ac_cv_func_vsnprintf_c99=${ac_cv_func_vsnprintf_c99=yes}
 glib_cv_compliant_posix_memalign=${glib_cv_compliant_posix_memalign=1}
 glib_cv_long_long_format=${glib_cv_long_long_format=ll}
+glib_cv_have_qsort_r=${glib_cv_have_qsort_r=no}
 
 #dbus-glib
 ac_cv_have_abstract_sockets=${ac_cv_have_abstract_sockets=yes}