]> code.ossystems Code Review - openembedded-core.git/commitdiff
freetype: disable bzip2 compressed font support
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Mon, 19 Sep 2011 10:58:36 +0000 (11:58 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 19 Sep 2011 12:14:03 +0000 (13:14 +0100)
If we do not disable this then it is enabled sometimes and disabled at
others depending on whether bzip2 has been built at the time, and worst
case it will cause a race condition if bzip2 is building at the same
time.

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/freetype/freetype_2.4.6.bb

index 8150dd41eb751a9431f1ba8ede888fff36175884..94a389ab425aed2604c1b63058d5afed943358e4 100644 (file)
@@ -13,7 +13,7 @@ LIC_FILES_CHKSUM = "file://docs/LICENSE.TXT;md5=28d5381b1bef2649c59f20c20bae4f39
 
 SECTION = "libs"
 
-PR = "r0"
+PR = "r1"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
            file://no-hardcode.patch"
@@ -28,7 +28,7 @@ inherit autotools pkgconfig binconfig
 LIBTOOL = "${S}/builds/unix/${HOST_SYS}-libtool"
 EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
 EXTRA_OEMAKE_virtclass-native = ""
-EXTRA_OECONF = "--without-zlib"
+EXTRA_OECONF = "--without-zlib --without-bzip2"
 
 do_configure() {
        cd builds/unix