]> code.ossystems Code Review - openembedded-core.git/commitdiff
pth: added 2.0.2 (from OE)
authorMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 14 Mar 2008 10:16:00 +0000 (10:16 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Fri, 14 Mar 2008 10:16:00 +0000 (10:16 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4001 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/pth/pth_2.0.2.bb [new file with mode: 0644]

diff --git a/meta/packages/pth/pth_2.0.2.bb b/meta/packages/pth/pth_2.0.2.bb
new file mode 100644 (file)
index 0000000..78c06bf
--- /dev/null
@@ -0,0 +1,29 @@
+DESCRIPTION = "GNU Portable Threads"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL FDL"
+PR = "r0"
+
+SRC_URI = "${GNU_MIRROR}/pth/pth-${PV}.tar.gz"
+
+PARALLEL_MAKE=""
+
+inherit autotools
+
+do_configure() {
+       gnu-configize
+       oe_runconf
+}
+
+do_stage() {
+       oe_libinstall -so libpth ${STAGING_LIBDIR}
+
+       install -d ${STAGING_INCDIR}/
+       for X in pth.h
+       do
+               install -m 0644 ${S}/$X ${STAGING_INCDIR}/$X
+       done
+
+       install -d ${STAGING_DATADIR}/aclocal
+       install pth.m4 ${STAGING_DATADIR}/aclocal/
+}