]> code.ossystems Code Review - openembedded-core.git/commitdiff
cmake-native: Add --enable-ccache to configure options
authorRobert Yang <liezhi.yang@windriver.com>
Thu, 24 Jan 2019 06:57:28 +0000 (14:57 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 24 Jan 2019 22:06:14 +0000 (22:06 +0000)
cmake-native requires --enable-ccache to enable ccache, target recipe doesn't
need this since it is already handled by cmake.bbclass.

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/cmake/cmake-native_3.12.2.bb

index 2f4ecc4f4cefb10addeaff6fab97a26d3aa46390..fedcf3d4bdb49400c4812852c9fddbe7f8bfd7d7 100644 (file)
@@ -29,6 +29,7 @@ CMAKE_EXTRACONF = "\
 do_configure () {
        ${S}/configure --verbose --prefix=${prefix} \
                ${@oe.utils.parallel_make_argument(d, '--parallel=%d')} \
+               ${@bb.utils.contains('CCACHE', 'ccache ', '--enable-ccache', '', d)} \
                -- ${CMAKE_EXTRACONF}
 }