]> code.ossystems Code Review - openembedded-core.git/commitdiff
lsb: Install init-functions to rpm package
authorXiaofeng Yan <xiaofeng.yan@windriver.com>
Tue, 17 May 2011 05:40:07 +0000 (13:40 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 17 May 2011 14:26:08 +0000 (15:26 +0100)
The script init-functions can't be built into rpm package of lsb.
I modify lsb_1.4.bb to add this script to rpm package of lsb.

Signed-off-by: Xiaofeng Yan <xiaofeng.yan@windriver.com>
meta/recipes-extended/lsb/lsb_1.4.bb

index 166ba4c87a5f2ea3445fac981cf5ec7dd8821d1d..fd0f12cb78ffda63304cc481e07f27bca2d52dd6 100644 (file)
@@ -3,7 +3,7 @@ SECTION = "console/utils"
 HOMEPAGE = "http://prdownloads.sourceforge.net/lsb"
 PRIORITY = "required"
 LICENSE = "GPLv2+"
-PR = "r0"
+PR = "r1"
 
 LIC_FILES_CHKSUM = "file://README;md5=12da544b1a3a5a1795a21160b49471cf"
 
@@ -94,4 +94,6 @@ do_install_append(){
                ln -sf ld.so.1 ld-lsb-ppc32.so.3
        fi      
 }
-FILES_${PN} += "/lib64"
+FILES_${PN} += "/lib64 \
+                ${base_libdir}/lsb/* \
+               "