]> code.ossystems Code Review - openembedded-core.git/commitdiff
Write DPKG_ARCH to /etc/apt/apt.conf
authorStefan Eichenberger <Stefan.Eichenberger@netmodule.com>
Fri, 8 Feb 2013 14:30:13 +0000 (15:30 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 12 Feb 2013 13:22:13 +0000 (13:22 +0000)
Apt does not recognize the architecture if a different one is set with
DPKG_ARCH (e.g. armel). This patch writes the correct architecture to
/etc/apt/apt.conf.

Signed-off-by: Stefan Eichenberger <stefan.eichenberger@netmodule.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-devtools/apt/apt_0.7.14.bb

index 667b700064b21ca7d31732e364c2e0fa43a2f678..7f1572bcd8738e89462efa3ff53985ae3a74b732 100644 (file)
@@ -16,3 +16,8 @@ require apt-package.inc
 FILES_${PN} += "${bindir}/apt-key"
 apt-manpages += "doc/apt-key.8"
 
+do_install_append() {
+    #Write the correct apt-architecture to apt.conf
+    APT_CONF=${D}/etc/apt/apt.conf
+    echo 'APT::Architecture "${DPKG_ARCH}";' > ${APT_CONF}
+}