]> code.ossystems Code Review - openembedded-core.git/commitdiff
gpgme: Convert to autotools_stage_all
authorRichard Purdie <rpurdie@linux.intel.com>
Mon, 16 Nov 2009 22:28:18 +0000 (22:28 +0000)
committerRichard Purdie <rpurdie@linux.intel.com>
Mon, 16 Nov 2009 22:28:18 +0000 (22:28 +0000)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/gpgme/gpgme_1.1.4.bb

index 8ac8bb339873473933978520999fbbeb49562d0b..826b3173510ecea5065912c6a8d20e44adf9260c 100644 (file)
@@ -7,19 +7,7 @@ PR = "r3"
 EXTRA_OECONF = "--with-pth=${STAGING_DIR}/${HOST_SYS} --without-pth-test \
                 --with-gpg=${bindir}/gpg --without-gpgsm"
 
-inherit autotools binconfig
-
-do_stage() {
-       autotools_stage_includes
-
-       install -d ${STAGING_LIBDIR}
-       oe_libinstall -C gpgme -so libgpgme ${STAGING_LIBDIR}
-       oe_libinstall -C gpgme -so libgpgme-pth ${STAGING_LIBDIR}
-       oe_libinstall -C gpgme -so libgpgme-pthread ${STAGING_LIBDIR}
-
-       install -d ${STAGING_DATADIR}/aclocal
-       install -m 0644 gpgme/gpgme.m4 ${STAGING_DATADIR}/aclocal/
-}
+inherit autotools_stage binconfig
 
 PACKAGES =+ "${PN}-pth ${PN}-pthread"
 FILES_${PN}-pth = "${libdir}/libgpgme-pth.so.*"