]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemu: Update qemu patches svn date.
authorRichard Purdie <richard@openedhand.com>
Tue, 16 Jan 2007 17:00:49 +0000 (17:00 +0000)
committerRichard Purdie <richard@openedhand.com>
Tue, 16 Jan 2007 17:00:49 +0000 (17:00 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1147 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/qemu/qemu-native_cvs.bb
meta/packages/qemu/qemu_cvs.bb

index 83d599771cca101cb0029cf4f50f065e8a20de92..01cc9c181d13f1d469797fcc794435b5802f67f0 100644 (file)
@@ -7,10 +7,12 @@ python __anonymous() {
     from bb import which, data
        
     path = data.getVar('PATH', d)
+    oeconf = data.getVar('EXTRA_OECONF', d) or ''
     if len(which(path, 'gcc-3.4')) != 0:
-        data.setVar('EXTRA_OECONF', " --cc=gcc-3.4", d)
+        data.setVar('EXTRA_OECONF', oeconf + " --cc=gcc-3.4", d)
     elif len(which(path, 'gcc34')) != 0:
-        data.setVar('EXTRA_OECONF', " --cc=gcc34", d)
+        data.setVar('EXTRA_OECONF', oeconf + " --cc=gcc34", d)
     elif len(which(path, 'gcc-3.3')) != 0:
-        data.setVar('EXTRA_OECONF', " --cc=gcc-3.3", d)
+        data.setVar('EXTRA_OECONF', oeconf + " --cc=gcc-3.3", d)
+    #data.setVarFlag('PKG_CONFIG_PATH', 'unexport', '1', d)
 }
index e738d934e70eaf66c81de8f9a532ba2d62f57bcd..501aa1dc5c5437fa8beed058a2010a9025784587 100644 (file)
@@ -7,7 +7,7 @@ FILESDIR = "${WORKDIR}"
 
 SRC_URI = "\
     cvs://anonymous@cvs.savannah.nongnu.org/sources/qemu;method=pserver;rsh=ssh;module=qemu \
-    svn://svn.o-hand.com/repos/misc/trunk/qemu-packaging/qemu;module=debian;proto=http;srcdate=20061207 \
+    svn://svn.o-hand.com/repos/misc/trunk/qemu-packaging/qemu;module=debian;proto=http;srcdate=20070116 \
     file://debian/patches/01_doc_typos.patch;patch=1;pnum=1 \
     file://debian/patches/02_snapshot_use_tmpdir.patch;patch=1;pnum=0 \
     file://debian/patches/03_machines_list_no_error.patch;patch=1;pnum=0 \
@@ -62,5 +62,7 @@ SRC_URI = "\
 
 S = "${WORKDIR}/qemu"
 
+#EXTRA_OECONF = "--disable-sdl"
+
 inherit autotools