]> code.ossystems Code Review - openembedded-core.git/commitdiff
alsa-tools: Fix recipe build error.
authorDongxiao Xu <dongxiao.xu@intel.com>
Thu, 14 Jul 2011 07:40:36 +0000 (15:40 +0800)
committerSaul Wold <sgw@linux.intel.com>
Wed, 20 Jul 2011 08:17:45 +0000 (01:17 -0700)
Remove some elements in alsa-tools to avoid build error and further
dependency on new recipes.

[YOCTO #1038]

Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
meta/recipes-multimedia/alsa/alsa-tools-1.0.24.1/autotools.patch [new file with mode: 0644]
meta/recipes-multimedia/alsa/alsa-tools_1.0.24.1.bb

diff --git a/meta/recipes-multimedia/alsa/alsa-tools-1.0.24.1/autotools.patch b/meta/recipes-multimedia/alsa/alsa-tools-1.0.24.1/autotools.patch
new file mode 100644 (file)
index 0000000..c7bc2d6
--- /dev/null
@@ -0,0 +1,34 @@
+Add parameters to autoreconf to support cross compile.
+Remove some sub-components which needs further recipe support.
+
+Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
+
+Upstream-Status: Inappropriate [configuration]
+
+diff -ruN alsa-tools-1.0.24.1-orig//ld10k1/gitcompile alsa-tools-1.0.24.1/ld10k1/gitcompile
+--- alsa-tools-1.0.24.1-orig//ld10k1/gitcompile        2011-07-06 11:27:40.227665002 +0800
++++ alsa-tools-1.0.24.1/ld10k1/gitcompile      2011-07-14 13:26:18.017665004 +0800
+@@ -1,6 +1,6 @@
+ #!/bin/bash
+-autoreconf -fi || exit 1
++autoreconf $ACLOCAL_FLAGS -fi || exit 1
+ export CFLAGS='-O2 -Wall -pipe -g'
+ echo "CFLAGS=$CFLAGS"
+ echo "./configure $@"
+diff -ruN alsa-tools-1.0.24.1-orig//Makefile alsa-tools-1.0.24.1/Makefile
+--- alsa-tools-1.0.24.1-orig//Makefile 2011-07-06 11:27:40.207665000 +0800
++++ alsa-tools-1.0.24.1/Makefile       2011-07-14 15:08:08.877665009 +0800
+@@ -1,9 +1,8 @@
+ VERSION = 1.0.24.1
+ TOP = .
+-SUBDIRS = ac3dec as10k1 envy24control hdsploader hdspconf hdspmixer \
+-        mixartloader pcxhrloader rmedigicontrol sb16_csp seq sscape_ctl \
+-        us428control usx2yloader vxloader echomixer ld10k1 qlo10k1 \
+-        hwmixvolume
++SUBDIRS = ac3dec as10k1 hdsploader mixartloader pcxhrloader sb16_csp \
++          seq sscape_ctl us428control usx2yloader vxloader ld10k1 \
++          hwmixvolume
+ all:
+       @for i in $(SUBDIRS); do \
index 5b3ea981d3b5d8dc02e7697f73964d5578284558..1bf9cd099a7607485810a3df4ab2a1ab744e85bf 100644 (file)
@@ -5,13 +5,16 @@ SECTION = "console/utils"
 LICENSE = "GPLv2"
 DEPENDS = "alsa-lib ncurses"
 
-PR = "r1"
+PR = "r2"
 
 LIC_FILES_CHKSUM = "file://hdsploader/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
 
-SRC_URI = "ftp://ftp.alsa-project.org/pub/tools/alsa-tools-${PV}.tar.bz2"
+SRC_URI = "ftp://ftp.alsa-project.org/pub/tools/alsa-tools-${PV}.tar.bz2 \
+           file://autotools.patch"
 
 SRC_URI[md5sum] = "08fe93a12006093e590d7ecc02b119dd"
 SRC_URI[sha256sum] = "17d43de93ab2db98886d89a53e45341daa46a4ef6edd405db87f4b5a5dc64a05"
 
 inherit autotools
+
+EXTRA_OEMAKE += "GITCOMPILE_ARGS='--host=${HOST_SYS} --build=${BUILD_SYS} --target=${TARGET_SYS} --with-libtool-sysroot=${STAGING_DIR_HOST}' ACLOCAL_FLAGS='-I ${STAGING_DATADIR}/aclocal'"